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1 Create a Ring with a Concave Top Surface 

In this tutorial, you will learn how to make a 
ring with a concave top surface. 

You will learn how to: 

• Use grid snap and object snaps 

• Use layers 

• Make circles and arcs to define the shape 
of the ring 

• Extend arcs  

• Join the arc segments into a single 
polycurve 

• Offset a polycurve to make a second 
polycurve 

 

• Turn on and move control points 

• Extrude the 2-D curves to make solids  

• Use zoom commands to change the view 

• Use the BooleanDifference command to hollow the ring's interior 

Starting a Model with a Template 
When starting a model in Rhino you can select a template to begin the modeling 
process. Templates contain information that helps you get started such as units, 
layers, viewport layouts, and toolbars. 

Selecting a default template sets the units for your model. For these examples, we 
will be using millimeters as our units. 

The templates include six predefined layers. Layers are a way of organizing objects so 
you can manipulate them separately or keep track of them in some way. It may help 
you to think of layers as transparent sheets where you can place different parts of 
your model. The predefined layers have color properties that will let you distinguish 
various parts more easily. 

Modeling aids can help you draw the 2-D geometry with more precision. In this 
tutorial you will use the snap and object snap (osnap) modeling aids. You can find 
the controls for modeling aids on the status bar at the bottom of the Rhino window. 

When Snap is on, the marker "snaps" between grid snap points. In this template, the 
grid snap is set at one-millimeter intervals to match the grid line intersections. 

Object snaps make it easy to snap precisely to various parts of the geometry. In this 
tutorial, we will use the End object snap to attach geometry at the end of another 
piece of geometry. 

Note Object snaps are crucial to accurate modeling. Never try to place things 
visually on the screen; it is too difficult, and it is impossible to ensure 
accuracy.  
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To start the model 

 On the File menu, click New, select Millimeters.3dm, and then click Open. 

To turn on modeling aids 

 On the status bar, click the Snap and Osnap panes.  

These controls are toggles. Click a pane once to turn the aid on; click again to 
turn it off. When modeling aids are turned on, the text in the pane is bold. 

 

Clicking the Osnap pane toggles the display of the Osnap toolbar.  

The Osnap pane text is bold only when one or more of the object snap check 
boxes are selected. 

 

You will be using the Osnap toolbar in this tutorial, so make sure it is 
displayed. 

Modeling the Shank Outline 
We will start by making an outline of the shank. First, we will maximize the Front 
viewport to make it easier to see. 

To maximize the Front viewport 

 In the Front viewport, double-click the viewport title. 

To make the inside of the shank 

1 On the Curve menu, click Circle, and then click Center, Radius. 

2 At the Center of circle … prompt, move 
your mouse pointer to the origin of the 
viewport construction plane (where the red 
and green axis lines meet) and click.  

Since grid snap is on, the cursor will 
snap exactly to the origin point where 
the axes meet. 
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3 At the Radius … prompt, type 9, and 
press ENTER. 

 

To make the outside of the shank 

1 On the Curve menu, click Arc, and then click Start, End, Point. 

2 At the Start of arc prompt, click a point 
2 mm (two grid lines) to the left of the left 
quadrant of the circle. 

3 At the End of arc prompt, click a point 
2 mm to the right of the right quadrant of 
the circle. 

 

4 At the Point on arc prompt, click a point 
1 mm from the bottom of the circle. 

 



  B A S I C  J E W E L R Y  M O D E L I N G  I N  R H I N O C E R O S  

Copyright © 2005 Robert McNeel & Associates. 8 

To make the top of the shank 

1 On the Curve menu, click Arc, and then click Start, End, Point. 

2 At the Start of arc prompt, click a point 
approximately 5 mm up from the top and 
4 mm to the left of the top of the circle. 

3 At the End of arc prompt, click a point 
8 mm to the right of the start point. 

 

4 At the Point on arc prompt, click a point 
4 mm from the top of the circle. 

 

To finish the curves for the shank 

1 On the Osnap toolbar, select the End check box. 

2 On the Curve menu, click Extend, and then click By Arc to a Point. 

3 At the Select curve to extend … prompt, click the upper left end of the arc 
that forms the bottom of the shank. 
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4 At the End of extension … prompt, move 
your mouse pointer until the End object 
snap causes it to snap to the left end of 
the arc at the top and click. 

 

5 Repeat steps 2 through 4 to extend the 
arc on the right side of the shank. 
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Creating the Inside Shank Curve 
Next, we will offset the outside curve to make another curve that defines the inside of 
the shank.  

To join the outside shank curves 

1 On the Edit menu, click Join. 

2 At the Select object to join prompt, click 
curve 1. 

3 At the Select curve to join prompt, click 
curve 2. 

This will join the two curves into one 
polycurve. 

 

To set the current layer 

The Layer pane displays the name of the current layer. In this case, the Layer pane 
should display the layer name "Default." 

 On the status bar, click the Layer pane, and then select the Layer 01 check 
box. 

This sets the current layer to Layer 01 so that the new offset curve will display 
in red, the color of Layer 01. 

To offset the joined curve 

1 Select the joined curve, if it is not already selected. 

2 On the Curve menu, click Offset Curve. 

3 At the ThroughPoint … prompt, type .8, and press ENTER. 

This sets the offset distance to 0.8 mm. 
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4 At the ThroughPoint… prompt, click 
inside the selected curve. 

 

A new curve is created 0.8 mm inside 
the original curve. 
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To edit the interior curve  

1 Select the red offset curve.  

2 On the Edit menu, click Control Points, 
and then click Control Points On. 

Control points appear surrounding the 
curve. These display as small squares. 
Control determine the shape of the 
curve. 

 

3 Select the three control points at the 
bottom of the curve. 

To select the points individually, hold the 
SHIFT key and click.  

Another way to select the points is to 
click and drag a window from left to right 
that encloses the three points. 

 

4 On the Transform menu, click Move.  

5 At the Point to move from prompt, click 
a point in the center of the ring. 

6 At the Point to move to prompt, click a 
point approximately 4 mm above the first 
point. 

7 On the Edit menu, click Control Points, 
and then click Control Points Off. 

This is so the solid created from this 
curve that will be used to hollow the ring 
will not cut through the lower part of the 
band.  
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Extruding Curves to Create the Solid Ring 
The next step is to make two extruded solids; one for the ring and another that will be 
used to cut out the inside of the shank. This operation will be easier to visualize if you 
can see all four viewports. 

To restore the four-viewport layout 

1 In the Front viewport, double-click the viewport title. 

2 On the View menu, click Zoom, and then click Extents All. 

The view zooms in each viewport to display all of the geometry. 

You can also rotate the mouse wheel to zoom in and out in the active 
viewport. 

To set the current layer 

 On the status bar, click the Layer pane, and then select the Default check 
box. 

This sets the current layer to Default. 

To extrude the shank curves 

1 Select the outer curve and the original 
circle. 

2 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

3 At the Extrusion distance … prompt, 
move your mouse pointer to the command 
line and click the options so they are set 
as follows: 

BothSides=Yes 
Cap=Yes 
Mode=Straight 
DeleteInput=No  

4 At the Extrusion distance … prompt, type 4, and press ENTER. 

The curves are extruded 4 mm on either side of the original curves making 
ring surfaces 8 mm wide, and adding flat surfaces on the two sides to make a 
complete solid. 
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To shade the viewport 

 In the Perspective viewport, right-click 
the viewport title, and then click Shaded 
Display. 

 

To set the current layer 

 On the status bar, click the Layer pane, and then select the Layer 01 check 
box. 

To extrude the interior curve 

1 Select the interior curve. 

2 On the Solid menu, click Extrude Planar Curve, and then click Straight. 

3 At the Extrusion distance … prompt, 
type 3, and press ENTER. 

The options should be set as before: 

BothSides=Yes 
Cap=Yes 
Mode=Straight 
DeleteInput=No 

 

Cutting Out the Shank  
We will finish the ring by removing the extruded interior solid from the ring solid using 
a Boolean operation. 

The three Boolean operations in Rhino are Union, Difference, and Intersection. 

The BooleanUnion command merges two or more intersecting solids into one piece. 
The BooleanDifference command removes one or more solids from another. The 
BooleanIntersection command leaves only the intersecting part of two or more 
solids. 
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To remove the center from the ring 

1 Select the ring solid. 

2 On the Solid menu, click Difference. 

 

3 At the Select second set of surfaces or 
polysurfaces … prompt, click the interior 
solid, and press ENTER 

 

The smaller cutout solid is removed from 
the shank of the ring. 

4 In the Perspective viewport, right-click 
and drag to rotate the view. 
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2 Create a Ring with Decorative Top Elements 

In this tutorial you will learn how to make 
another style of ring. 

In addition to practicing the techniques from the 
previous tutorial, you will learn how to: 

• Use Ortho to draw at 90-degree 
increments. 

• Use the Mirror command to model 
symmetrical objects. 

• Use Fillet to make rounds between two 
curves. 

 

Note: You should complete the tutorial in the previous chapter before starting this 
tutorial. 

To start the model 

 On the File menu, click New, select Millimeters.3dm, and then click Open. 

To turn on modeling aids 

1 On the status bar, click the Snap and Osnap panes.  

2 On the status bar, click the Ortho pane. 

When Ortho is on, cursor movement is restricted to points at multiples of a specified 
angle from the last point created. The default angle is 90 degrees. 

Modeling the Shank 
We will start by making the outline of the shank. 

To maximize the Front viewport 

 In the Front viewport, double-click the viewport title. 

To make the inside of the shank 

1 On the Curve menu, click Circle, and then click Center, Radius. 
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2 At the Center of circle … prompt, move 
your mouse pointer to the origin of the 
viewport construction plane and click.  

 

3 At the Radius … prompt, type 9, and 
press ENTER. 

 

To make the outside of the shank 

1 On the Curve menu, click Arc, and then click Start, End, Point. 

2 At the Start of arc prompt, click a point 2 mm (two grid lines) to the left of the 
left quadrant of the circle. 

3 At the End of arc prompt, click a point 
2 mm to the right of the right quadrant of 
the circle. 
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4 At the Point on arc prompt, click a point 
1 mm from the bottom of the circle. 

 

To finish the outside of the shank 

1 On the Curve menu, click Line, and then click Single Line. 

2 At the Start of line …  prompt, set the BothSides option to Yes. 

This lets you make a line from a middle point with symmetry. 

3 At the Middle of line… prompt, click a 
point 1 mm up from the top quadrant of 
the circle. 

 

4 At the End of line prompt, type 9, and press ENTER. 

Typing a value and pressing ENTER sets a constraint for the length. The result 
is no matter where you click, the line will be 9 units from the middle point on 
both sides. 
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5 At the End of line prompt, move your 
mouse to the right and click. 

The cursor movement is constrained to 
90-degree angles by the Ortho setting 
and to 9 mm by the distance constraint. 

 

To make the top inside part of the shank oval 

1 Select the circle.  

2 On the Edit menu, click Control Points, 
and then click Control Points On. 

 

3 Select the three control points at the top 
of the circle. 
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4 On the Transform menu, click Move.  

5 At the Point to move from prompt, click 
the point at the top of the circle. 

6 At the Point to move to prompt, click the 
middle of the line. 

 

7 On the Edit menu, click Control Points, and then click Control Points Off. 

To finish the curves for the shank 

1 On the Osnap toolbar, select the End check box. 

2 On the Curve menu, click Extend, and then click By Arc to a Point. 

3 At the Select curve to extend … prompt, use the End object snap to select the 
upper left end of the arc that forms the bottom of the shank. 

4 At the End of extension prompt, use the 
End object snap to select the the left end 
of the line at the top and click. 

 

5 Repeat these steps to extend the arc on 
the right side of the shank. 

 

To make the center arc for the top of the ring 

1 On the Curve menu, click Line, and then click Single Line. 

2 At the Start of line …  prompt, set the BothSides option to Yes. 

3 At the Middle of line… prompt, click a point 3 mm above the top quadrant of 
the oval. 

4 At the End of line prompt, type 4, and press ENTER. 



  B A S I C  J E W E L R Y  M O D E L I N G  I N  R H I N O C E R O S  

Copyright © 2005 Robert McNeel & Associates. 21 

5 At the End of line prompt, move your 
mouse pointer to the right and click. 

 

6 On the Curve menu, click Arc, and then 
click Start, End, Direction. 

7 At the Start of arc prompt, snap to one 
end of the line and click. 

8 At the End of arc prompt, snap to other 
end of the line and click. 

9 At the Direction at start prompt, click a 
point directly above the first point. 

 

  

To make the side arcs 

1 On the status bar, click the Ortho pane to toggle Ortho off. 

2 On the Curve menu, click Arc, and then 
click Start, End, Direction. 

3 At the Start of arc prompt, use the End 
object snap to start the arc at the left 
corner of the shank. 

4 At the End of arc prompt, use the End 
object to end the arc at the left end of the 
upper arc. 

5 At the Direction at start prompt, drag and 
click to make the arc as illustrated. 

 

To mirror the arc to the other side 

1 Turn Ortho on. 
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2 Select the arc you just created. 

3 On the Transform menu, click Mirror. 

4 At the Start of mirror plane … prompt, click in the center of the ring. 

5 At the End of mirror plane … prompt, use 
Ortho to click directly above the first point. 

 

6 Select the two construction lines, and press 
DELETE. 

 

To make a radius between the arcs 

1 On the Curve menu, click Fillet Curves. 

2 At the Select first curve to fillet … prompt, type .2, and press ENTER. 

This sets the fillet radius to 0.2. 

3 At the Select first curve to fillet … prompt, click the Join option. 

This joins the arcs at the same time it makes the round. 

Check the options to see that they are set as follows: 

Radius=0.2 
Join=Yes 
Trim=Yes 
DeleteInput=No 
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4 At the Select first curve to fillet … 
prompt, click near the end of one of the 
arcs (1). 

5 At the Select second curve to fillet … 
prompt, click near the end of the adjacent 
arc. 

Another arc is drawn between the arcs, 
the original arcs are trimmed back to the 
ends of the fillet, and the three parts are 
joined. 

 

6 Repeat this step for the other side (2). 
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Creating the Inside Curve 
Next we will make a copy of the outside of the ring to use to cut out the inside of the 
shank.  

To make the curve that defines the inside of the shank 

1 Select all the curves that form the outer 
part of the ring.  

2 On the Edit menu, click Join. 

This will join the curves into one 
polycurve.  

 

To set the current layer 

 On the status bar, click the Layer pane, and then select the Layer 01 check 
box. 

To offset the curve 

1 Select the joined curve. 

2 On the Curve menu, click Offset Curve. 

3 At the ThroughPoint … prompt, type .8, and press ENTER. 

4 At the ThroughPoint … prompt, click 
inside the selected curve. 
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A new curve is created 0.8 mm inside the 
original curve. 

 

To adjust the curve to move the lower part out of the way of the band 

1 Select the offset curve you just created.  

2 On the Edit menu, click Control Points, 
and then click Control Points On. 

 

3 Select the three control points at the 
bottom of the curve. 
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4 On the Transform menu, click Move.  

5 At the Point to move from prompt, click a 
point at the bottom of the curve. 

6 At the Point to move to prompt, click a 
point approximately 4 mm above the first 
point. 

 

7 On the Edit menu, click Control Points, and then click Control Points Off. 

Extruding Curves to Create the Solid Ring 
The next step is to make two solid extrusions; one for the ring and another for the 
inside of the shank. This section will be easier if you can see all four viewports. 

To restore the four-viewport layout 

1 In the Front viewport, double-click the viewport title. 

2 On the View menu, click Zoom, and then click Extents All. 

To set the current layer 

 On the status bar, click the Layer pane, and then select the Default check 
box. 

This sets the current layer to Default. 

To extrude the shank curves 

1 Select the outer curve and the circle. 

2 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

3 At the Extrusion distance … prompt, 
move your mouse pointer to the command 
line and click the options so they are set 
as follows: 

BothSides=Yes 
Cap=Yes 
Mode=Straight 
DeleteInput=No 
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4 At the Extrusion distance … prompt, 
type 4, and press ENTER. 

The curves are extruded 4 mm on either 
side of the original curve giving the ring 
a thickness of 8 mm. 

 

To set the current layer 

 On the status bar, click the Layer pane, and then select the Layer 01 check 
box. 

To extrude the interior curve 

1 Select the interior curve. 

2 On the Solid menu, click Extrude Planar Curve, and then click Straight. 

3 At the Extrusion distance … prompt, 
type 3, and press ENTER. 

The options should be set as before: 

BothSides=Yes 
Cap=Yes 
Mode=Straight 
DeleteInput=No 
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Cutting Out the Shank 
We will finish the ring by removing the extruded interior solid from the ring solid using 
a Boolean operation. 

To remove the center from the ring 

1 Select the ring extrusion. 

2 On the Solid menu, click Difference. 

 

3 At the Select second set of surfaces or 
polysurfaces … prompt, select the 
interior solid. 

 

4 At the Select second set of surfaces … 
prompt, press ENTER. 

The smaller extrusion is removed from 
the shank of the ring. 
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3 Create a Simple Band Ring 

In this tutorial you will learn how to make a 
simple band ring with scallop detailing. 

In addition to practicing the techniques you 
learned in the previous chapters, you will learn 
how to: 

• Make a surface with a 1 Rail Sweep  

 

Note: You should complete the tutorials in the previous chapters before starting this 
tutorial. 

To start the model 

 On the File menu, click New, select Millimeters.3dm, and then click Open. 

To turn on modeling aids 

 On the status bar, click the Snap, Ortho, and Osnap panes.  

Modeling the Shank Inner Curve 
We will start by making an outline of the shank. 

To maximize the Front viewport 

 In the Front viewport, double-click the viewport title. 

To make the inside of the shank 

1 On the Curve menu, click Circle, and then click Center, Radius. 
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2 At the Center of circle … prompt, move 
your mouse pointer to the origin of the 
viewport construction plane (where the red 
and green axes lines meet) and click.  

Since grid snap is on, the cursor will 
snap exactly to the origin point where 
the axes meet. 

 

3 At the Radius … prompt, type 9, and 
press ENTER. 

 

To make a reference point on the circle 

1 On the Osnap toolbar select the End, Point, and Quad check boxes. 

2 On the Curve menu, click Point Object, and then click Single Point. 

3 At the Location of point object prompt, 
use the Quad object snap to place the 
point at the top quadrant of the circle. 

This will give us a reference point for 
creating the cross-section of the band. 
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Creating the Shank Cross-Section Profile 
In this section you will create the cross-section profile curve that will be swept around 
the shank curve. 

To maximize the Right viewport 

1 In the Front viewport, double-click the viewport title to restore the four-
viewport layout. 

2 In the Right viewport, double-click the viewport title. 

To make the construction lines for the cross-section curve 

1 On the Curve menu, click Line, and then click Single Line. 

2 At the Start of line … prompt, click BothSides. 

3 At the Middle of line … prompt, click the reference point you created in the 
previous section. 

4 At the End of line prompt, type 5, and press ENTER. 

5 At the End of line prompt, move your 
mouse to the right and click. 

The cursor movement is constrained to 
90-degree angles by the Ortho setting 
and to 5 mm by the distance constraint. 

 

6 On the Curve menu, click Line, and then click Single Line. 

7 At the Start of line… prompt, click the left end of the line you just created. 

8 At the End of line prompt, type 1, and press ENTER. 
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9 At the End of line prompt, click directly 
above the first point. 

 

To create the first arc 

1 On the Curve menu, click Arc, and then click Start, End, Direction. 

2 At the Start of arc prompt, use the End object snap to start the arc at the 
upper end of the line you just created. 

3 At the End of arc prompt, move your mouse pointer two grid points to the right 
and click. 

4 At the Direction at start prompt, click a 
point directly above the first point. 

 

To mirror the arc and the line segment 

1 Select the arc and the vertical line segment you just created. 

2 On the Transform menu, click Mirror. 

3 At the Start of mirror… prompt, snap to the reference point. 
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4 At the End of mirror plane… prompt, 
click directly above the first point. 

 

To finish the cross-section curve 

1 On the Curve menu, click Arc, and then click Start, End, Point. 

2 At the Start of arc prompt, use the End object snap to start the arc at the end 
of one of the side arcs. 

3 At the End of arc prompt, use the End object snap to end the arc at the end of 
the other arc. 

4 At the Point on arc prompt, click a point 
2 mm up from the reference point. 
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To join the cross-section curve 

1 Select the three line segments and the 
three arcs. 

2 On the Edit menu, click Join. 

 

To restore the four viewport layout 

 In the Right viewport, double-click the viewport title. 

To finish the band ring 

1 On the Surface menu, click Sweep 1 
Rail. 

2 At the Select rail curve prompt, click the 
circle (1). 

3 At the Select cross section curves …  
prompt, click the cross-section you just 
created (2), and press ENTER. 

 

4 In the Sweep 1 Rail Options dialog box, 
click OK. 
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4 Create an Eternity Ring with Claw Settings 

In this tutorial, you will learn how to make a 
ring with a specified number of elements evenly 
spaced around the shank of the ring. The ring 
we will make will have twenty-two elements. 

In an eternity ring you usually have the problem 
of matching the size and a specific number of 
stones, or you may have a constraint given by 
the size of the stones. The polar array command 
will solve this problem.  

A polar array is a repetition of items around a 
center where you can specify the number of 
elements and the angle to fill. 

 

In addition to practicing techniques you learned in the previous chapters, you will 
learn how to: 

• Array objects around a circle 

• Trim and chamfer curves 

• Make a revolved surface  

Note: You should complete the tutorials in the previous chapters before starting this 
tutorial. 

To start the model 

 On the File menu, click New, select Millimeters.3dm, and then click Open. 

To turn on modeling aids 

 On the status bar, click the Snap and Osnap panes.  

Modeling the Shank 
We will start by making an outline of the shank. 

To maximize the Front viewport 

 In the Front viewport, double-click the viewport title. 

To make the inside of the shank 

1 On the Curve menu, click Circle, and then 
click Center, Radius. 
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2 At the Center of circle… prompt, move 
your mouse pointer to the origin of the 
viewport and click. 

 

3 At the Radius … prompt, type 9, and 
press ENTER. 

 

Create the Claw to Array 
Next we will make a copy of the inside of the ring to use for a construction curve for 
the outer part of the ring.  

Create a construction circle for the outside of the shank 
The construction circle provides the outer boundary of the arrayed elements 
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To create the construction circle 

1 Select the circle you just created. 

2 On the Curve menu, click Offset Curve. 

3 At the Through point … prompt, type .2, 
and press ENTER. 

4 At the Through point … prompt, click 
outside the first circle. 

 

Create construction lines 
Next we will make the rest of the construction lines for the claw elements. We will 
start by making a single line and arraying around the circle 22 times. This will give us 
the proper spacing for the elements. The spacing is determined by the number of 
stones that will be placed in the ring. 

To make a construction line 

1 On the Osnap toolbar, select the Cen check box. 

2 On the Curve menu, click Line, and then click Single Line. 

3 At the Start of line … prompt, move your 
mouse pointer over one of the circles, and 
click when the Cen osnap tooltip appears. 

4 At the End of line … prompt, click a 
point 2 mm to the right of the right 
quadrant of the outer circle. 

 

To array the construction line in a circle 

1 Select the line you just created. 

2 On the Transform menu, click Array, and then click Array Polar. 

3 At the Center of polar array prompt, snap to the center of the circles. 

4 At the Number of items … prompt, type 22, and press ENTER. 
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5 At the Angle to fill <360> prompt, press 
ENTER to accept the default value. 

 

To delete the unnecessary lines 

Now that the spacing for the elements has been established by the array, you can 
delete all but the two lines that you will use to construct the claw feature. 

 Select all of the lines except the two that 
are located at either side of the top of the 
circle, and press DELETE. 

 

To make the construction curves for the starting element 

1 On the Osnap toolbar, select the Quad check box, and clear the Cen check box. 

2 On the Curve menu, click Circle, and then click Center, Radius. 
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3 At the Center of circle … prompt, use the Quad osnap to place the center of 
the circle at the top quadrant of the outside construction circle. 

4 At the Radius … prompt, type .8, and 
press ENTER. 

 

5 Select the three circles and two lines. 

 

6 On the Edit menu, click Trim. 

7 At the Select object to trim prompt, click 
the tops of the two lines, the left and 
middle of the outside circle, and the top of 
the small circle, and press ENTER. 

The point on the curve you pick 
determines the part that will be 
removed.  

The result should match the illustration. 

 

To chamfer the edges of the starting element 

1 On the Curve menu, click Chamfer Curves. 

2 At the Select first curve to chamfer … prompt, click Distances. 

3 At the First chamfer distance … prompt, type .4, and press ENTER. 



  B A S I C  J E W E L R Y  M O D E L I N G  I N  R H I N O C E R O S  

Copyright © 2005 Robert McNeel & Associates. 40 

4 At the Second chamfer distance … prompt, type .4, and press ENTER. 

5 At the Select first curve to chamfer … 
prompt, click on the line (1). 

6 At the Select second curve to 
chamfer … prompt, click the arc 
segment (2). 

 

7 Repeat these steps to chamfer the line 
and the arc segment on the right side. 

8 Delete the left and right construction 
lines. 

 

9 Select the four remaining lines and arcs. 

10 On the Edit menu, click Join. 
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Arraying the Claw Profile Around the Ring 
Next we will array the single claw feature around the ring. 

To array the claw profile 

1 On the Osnap toolbar, select the Cen check box, and clear the Quad check box. 

2 Select the joined curves you just created. 

3 On the Transform menu, click Array, and then click Array Polar. 

4 At the Center of polar array prompt, snap 
to the center of the circle. 

5 At the Number of items <22> prompt, 
press ENTER. 

6 At the Angle to fill <360> prompt, press 
ENTER. 

 

Extruding the Curves to Create the Solid Ring 
The next step is to extrude the inside and the outside curves to form the main part of 
the band. This section will be easier if you can see all four viewports. 

To restore the four-viewport layout 

1 In the Front viewport, double-click the viewport title. 

2 On the View menu, click Zoom, and then click Extents All. 
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To extrude the shank curves 

1 Set the current layer to Layer 01. 

2 Select the claw curves and the circle. 

3 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

4 At the Extrusion distance … prompt, 
click BothSides. 

 

5 At the Extrusion distance … prompt, 
type 1.5, and press ENTER. 

The curves are extruded 1.5 mm on 
either side of the original curves giving 
the ring a thickness of 3 mm. 

 

Creating the Channel 
The next step is to make a revolved surface to cut out a channel in the outside of the 
ring. 

To make the construction curves for the channel 

1 Set the current layer to Default. 

2 On the Curve menu, click Circle, and then click Center, Radius. 
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3 At the Center of circle … prompt, use 
the Cen object snap to start the circle at 
the center of the shank circle. 

4 At the Radius … prompt, type 11.5, and 
press ENTER. 

 

5 On the Osnap toolbar, select the Quad check box, and clear the Cen check box. 

6 On the Curve menu, click Circle, and then click Center, Radius. 

7 At the Center of circle … prompt, in the 
Right viewport, use the Quad object snap 
to the circle quadrant at the top of the 
construction circle you just created. 

8 At the Radius … prompt, type 1, and 
press ENTER. 

 

To make the revolved surface 

1 Turn Ortho on. 

2 Select the circle you just created. 

3 On the Surface menu, click Revolve. 

4 At the Start of revolve axis prompt, type 0, and press ENTER. 

This sets start point at the construction plane origin. 
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5 At the End of revolve axis prompt, move 
your mouse pointer to the Perspective 
viewport, and then along the world y-axis 
and click. 

A tubular surface is created around the 
circumference of the ring. 

 

Cut the Channel 
We will finish the ring by using the revolved surface to cut a channel in the ring. 

To cut the channel 

1 Select the ring solid. 

2 On the Solid menu, click Difference. 
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3 At the Select second set of surfaces or 
polysurfaces … prompt, select the 
revolved surface, and press ENTER. 

 

The revolved surface is removed from 
the outside of the ring. 

 



  B A S I C  J E W E L R Y  M O D E L I N G  I N  R H I N O C E R O S  

Copyright © 2005 Robert McNeel & Associates. 46 

5 Create a Ring with Gemstones 

In this tutorial you will learn how to make 
another style of extruded ring. 

In addition to practicing the techniques you 
learned in the previous chapters, you will learn 
how to: 

• Import a model to add pre-made features  

• Rotate an object 

• Copy curves 

• Add control points to a curve by inserting 
knots 

• Hide curves 

• Make a surface lofted between curves 

 

• Make surfaces from planar curves 

• Use a sweep a curve along two rail curves to make surfaces  

• Join surfaces into a closed polysurface 

Note: You should complete the tutorials in the previous chapters before starting this 
tutorial. 

To start the model 

 On the File menu, click New, select Millimeters.3dm, and then click Open. 

To turn on modeling aids 

 On the status bar, click the Snap and Osnap panes.  

Draw the Initial Shank Outline Shape 
We will start by making an outline of the shank. 

To maximize the Front viewport 

 In the Front viewport, double-click the viewport title. 
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To make the inside of the shank 

1 On the Curve menu, click Circle, and then 
click Center, Radius. 

2 At the Center of circle … prompt, move 
your mouse pointer to the origin of the 
viewport and click.  

 

3 At the Radius … prompt, type 9, and 
press ENTER. 

 

To make the outside of the shank 

1 On the Curve menu, click Arc, and then click Start, End, Point. 

2 At the Start of arc prompt, click a point 2 mm (two grid lines) to the left of the 
left quadrant of the circle. 

3 At the End of arc prompt, click a point 
2 mm to the right of the right quadrant of 
the circle. 
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4 At the Point on arc prompt, click a point 
1 mm from the bottom of the circle. 

 

Adding Gemstones 
Because the size of the ring depends on the size and number of gemstones, the next 
step is to insert a model of a stone. We will then scale and position the stone and copy 
it. The rest of the model will be created around the size and position of the stones.  

Importing a gemstone model 
Before importing a gemstone model, we will make a reference point to make placing 
the stone easier. 

To make a reference point for inserting the stone 

1 On the Curve menu, click Point Object, and then click Single Point. 

2 At the Location of point object prompt, 
click a point 4 mm above the top of the 
circle. 

 

3 On the Osnap toolbar, select the Point check box, and clear all other check 
boxes. 

Since the gemstone model we are inserting is exactly one unit (millimeter) square, we 
can scale it when we insert it. We want to have a stone that is 5 mm square and 5 mm 
high. 
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To insert the stone 

1 On the File menu, click Insert. 

2 On the Insert dialog box, click File and navigate to the folder where you saved 
these tutorial files, and select Square_05.3dm. 

3 Under Insertion point, select the Prompt check box. 

4 Under Scale, select the Uniform check box, in the X box type 5.0, and click 
OK. 

5 At the Insertion point prompt, in the 
Top viewport, use the Point object snap to 
place the stone at the point object you 
just created. 

 

 

Place another gemstone 
For the next gemstone, you will copy and rotate your original gemstone model.  

To copy the stone 

1 Maximize the Perspective viewport. 

2 Select the stone you just inserted. 

3 On the Transform menu, click Copy.  
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4 At the Point to copy from prompt, use 
the End object snap to start at the lower 
left end of the stone (1). 

5 At the Point to copy to prompt, use the 
End object snap to end at the lower right 
end of the stone (2). 

 

To rotate the stone 

1 Maximize the Front viewport. 

2 Select the stone you just copied. 

3 On the Transform menu, click Rotate. 

4 At the Center of rotation … prompt, use 
the End object snap to click the lower left 
end of the selected stone, as 
illustrated (1). 

5 At the Angle or first reference … 
prompt, move your mouse pointer to the 
right and click. 

6 Turn Ortho off. 

- Or - 

Hold SHIFT to suspend Ortho for the 
next mouse click. 

7 At the Second reference … prompt, 
move your mouse pointer down slightly 
and click. 

 

Place the third gemstone 
You will now mirror the second gemstone around the center of the ring to create a 
third gemstone. In addition to the gemstone, we want to create a small construction 
line that will help define the edge of the mounting. You will also mirror this line to the 
other side to make the setting symmetrical. 

To make a construction line to help define the ring edge 

1 Turn Ortho on. 

2 On the Curve menu, click Line, and then click Single Line. 
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3 On the Osnap toolbar, click Project. 

The Project object snap mode projects the object snap point to the 
construction plane. When you start the line using the End object snap, instead 
of snapping to the corner of the stone, the snap point is projected to the 
construction plane and the line will start at the center of the stone's edge 
where the construction plane and the stone intersect. 

4 At the Start of line … prompt, use the 
End object snap projected to the 
construction plane to start the line at the 
right edge of the stone as illustrated. 

5 At the End of line prompt, type 1.4, and 
press ENTER. 

6 At the End of line prompt, move your 
mouse to the right and click. 

 

To mirror the stone and the construction line 

1 Select the copied stone and the line you just created. 

2 On the Transform menu, click Mirror. 

3 At the Start of mirror plane … prompt, 
use the Cen object snap to start the mirror 
plane at the center of the ring. 

4 At the End of mirror plane … prompt, use 
Ortho to click directly above the first point. 
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Making the Finished Shank Curves 
We can now add the curves that define the shape of the interior and exterior of the 
shank. 

To create the lower outside edge curve 

1 On the Curve menu, click Extend, and then click By Arc to a Point. 

2 At the Select curve to extend … prompt, click the upper left end of the arc 
that will form the bottom of the shank. 

3 At the End of extension … prompt, use 
the End object snap to end the arc 
extension at the left end of the top arc. 

4 Repeat this command to extend the arc 
on the right side of the shank. 

 

To make an arc that defines the shape at the top 

1 Turn Ortho off. 

2 On the Curve menu, click Arc, and then click Start, End, Direction. 

3 At the Start of arc … prompt, use the End 
object snap to start the arc at the top left 
end of the arc you just created. 

4 At the End of arc … prompt, use the End 
object snap to end the arc at the top right 
end of the arc you just created. 
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5 At the Direction at start … prompt, move 
your mouse pointer up until the curve 
roughly follows the profile of the stones as 
shown and click. 

 

Making the Interior Opening 
Next we will make a copy of the outside of the ring to use to cut out the inside of the 
shank and the opening for the stones in the top of the ring. 

To make the curve that defines the inside of the shank  

1 Set the current layer to Layer 01. 

2 Select the curve that forms the outer part of the ring. 

3 On the Curve menu, click Offset Curve. 

4 At the ThroughPoint … prompt, type .8, and press ENTER. 

5 At the ThroughPoint … prompt, click 
inside the selected curve. 
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To edit the curve shape 

1 Select the offset curve. 

2 On the Edit menu, click Control Points, 
and then click Control Points On. 

3 Select the three control points at the 
bottom of the curve. 

4 On the Transform menu, click Move.  

5 At the Point to move from prompt, click a 
point in the center of the ring. 

6 At the Point to move to prompt, click a 
point approximately 4 mm above the first 
point. 

 

Edit the interior curve's shape 
To make adjustment to the upper part of the offset curve without changing the lower 
part of the curve, it will be necessary to add additional control points.  

One way to add control points to the curve with control over their position, is to add 
knots to the curve. For each knot we add, a control point will also be added. 

Note: A knot is property of the curve where the mathematical definition of the curve 
changes. Imagine a rope. If you hold it at the ends, the rope will sag according 
to the laws of nature (gravity, the stiffness of the rope, etc.) with a 
mathematical definition. If you tie it off somewhere along its length (by 
putting knots in it), there will be a different definition (sag) for each segment 
between the knots. 

To add control points 

1 On the Edit menu, click Control Points, and then click Insert Knot. 

2 At the Point on curve to add knot … prompt, click approximately half way 
between the two uppermost control points on the offset curve. 
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3 At the Point on curve to add knot … 
prompt, click approximately half way 
between the inserted knot and the next 
control point down the offset curve. 

4 At the Point on curve to add knot … 
prompt, press ENTER to end the command. 

The new control points will not be visible 
until the InsertKnot command has 
ended. 

 

5 Drag the control points to match the 
illustration at the right. 

It is important that the vertical segment 
at the top intersects the edge of the 
stone. 

6 On the Edit menu, click Control Points, 
and then click Control Points Off. 

 

To create the other side of the curve 

Since it would be difficult to repeat the previous steps exactly to make the other side 
of the curve symmetrical, the next two steps demonstrate how to make the curve 
symmetrical on each side of the ring.  

1 Turn Ortho on. 

2 On the Curve menu, click Line, and then click Single Line. 

3 At the Start of line … prompt, type 0, and 
press ENTER. 

This starts the line at the construction 
plane origin. 

4 At the End of line prompt, move your 
mouse down and click. 

Make sure your line intersects the offset 
curve. 
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To trim the offset curve 

1 Select the line you just created. 

2 On the Edit menu, click Trim.  

3 At the Select object to trim prompt, click 
the right side of the offset curve. 

4 At the Select object to trim prompt, 
press ENTER to end the command. 

 

 

To mirror the curve 

1 Select the trimmed offset curve. 

2 On the Transform menu, click Mirror.  
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3 At the Start of mirror plane … prompt, 
use the Cen object snap to start the 
mirror plane in the center of the ring. 

4 At the End of mirror plane … prompt, 
use the End object snap to end the mirror 
plane at the end of the offset curve. 

 

To make the closed solid you will use to cut out the interior of the ring, connect the 
two arcs with a line and join these pieces. 

To close the curves 

1 On the Curve menu, click Line, and then 
click Single Line. 

2 At the Start of line … prompt, use the 
End object snap to start the line at the 
end of the offset curve. 

3 At the End of line prompt, use the End 
object snap to end the line at the end of 
the mirrored curve. 

4 Select the line you just created and the 
two offset curves. 

5 On the Edit menu, click Join. 
 

Making the Curves that Define the Exterior Shape 
The next step is to make copies of the curves you created. Then you will make 
construction curves to be used to make surfaces. Working in the Perspective viewport 
will make this step easier to complete. 

To set the layer 

1 Set the current layer to Default. 

2 Turn Layer 01 off. 
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To copy the shank curves 

1 Select the outer curve, the circle, and the 
curve for the top. 

2 On the Transform menu, click Copy. 

3 At the Point to copy from prompt, 
type 0, and press ENTER. 

4 At the Point to copy to prompt, 
type 3.7, and press ENTER. 

 

5 At the Point to copy to prompt, move 
your mouse pointer along the y-axis and 
click. 

6 At the Point to copy to prompt, 
type 3.7, and press ENTER. 

7 At the Point to copy to prompt, move 
your mouse pointer the opposite direction 
along the y-axis and click. 

8 At the Point to copy to prompt, press 
ENTER to end the command. 

 

9 With the original curves still selected, 
from the Edit menu, click Visibility, and 
then click Hide. 

This will remove the original curves 
from the view. 

 

To make a cross-section curve for the side and top surfaces or the ring 

1 Turn Ortho off. 

2 On the status bar click Planar. 

Planar mode aids in creating planar objects with commands that allow free 
picking. Successive pick points will have the same construction plane elevation 
as the first point. 
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3 On the Osnap toolbar, click Project. 

This will turn Osnap projection mode off, letting you to snap to the ends of the 
curves you copied, which are not on the construction plane.  

4 On the Curve menu, click Arc, and then click Start, End, Direction. 

To make the curve, it will be necessary to move your mouse pointer between 
the Perspective viewport and the Top viewport while picking points. 

5 At the Start of arc … prompt, in the 
Perspective viewport use the End object 
snap to start the arc at the top right end 
of one of the curves you copied. 

6 At the End of arc … prompt, in the 
Perspective viewport, use the End 
object snap to end the arc click top right 
end of the other curve you copied. 

 

7 At the Direction at start … prompt, 
move your mouse pointer to the Top 
viewport, drag the arc shape, and click to 
approximate the direction illustrated. 

 

To rotate the cross-section curve 

1 Select the curve you just created. 

2 On the Transform menu, click Rotate. 
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3 At the Center of rotation … prompt, in 
the Front viewport , use the End object 
snap to place the center of rotation at the 
end of the arc. 

4 At the Angle or first reference point … 
prompt, move your mouse pointer to the 
right and click. 

5 At the Second reference point … 
prompt, move your mouse pointer up to 
approximate the direction illustrated. 

 

 

To mirror the cross-section curve 

1 Turn Ortho on. 

2 Select the curve you just created. 

3 On the Transform menu, click Mirror.  

4 At the Start of mirror plane … prompt, 
type 0, and press ENTER. 

5 At the End of mirror plane … prompt, 
use Ortho to move your mouse pointer 
up and click. 
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Making the Exterior Surfaces 
The next step is to make the surfaces for the outside of the shank and the top of the 
ring. 

To make the surface for the outside of the shank 

1 Set the current layer to Layer 02. 

2 Select the two curves that form the shank. 

3 On the Surface menu, click Sweep 2 Rails. 

4 At the Select cross section curves … 
prompt, click one of the cross-section arcs 
you just created. 

5 At the Select cross section curves. … 
prompt, select the other arc you just 
mirrored, and press ENTER. 

6 In the Sweep 2 Rail Options dialog box, 
click OK. 

 

To make the surface for the top of the ring 

1 Select the two curves at the front and 
back of the top that run along the sides of 
the gems. 

2 On the Surface menu, click Sweep 2 
Rails. 

3 At the Select cross section curves … 
prompt, click the two top edges of the 
surface you just created. 

4 At the Select cross section curves … 
prompt, press ENTER. 
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5 In the Sweep 2 Rail Options dialog box, 
click OK. 

 

Making the Interior Surface 
The next step is to make a surface for the inside of the shank. 

To make the lofted surface 

1 Select the two circles. 

2 On the Surface menu, click Loft. 

3 At the Adjust curve seams … prompt, 
press ENTER. 

 

4 In the Loft Options dialog box, click OK.  
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Making the Front and Back Surfaces 
The next step is to make a planar surface for the front and back of the ring. 

To make the planar surface 

1 On the Surface menu, click Planar Curves. 

2 At the Select planar curves to build surface prompt, select the three surface 
edges at the front of the ring. 

3 At the Select planar curves to build surface … prompt, press ENTER. 

4 Repeat these steps for the back of the 
ring. 

 

To join the surfaces into one closed polysurface 

1 Select all five surfaces. 

2 On the Edit menu, click Join.  
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Making a Solid to Cut the Opening in the Top Surface 
The next step is to make an extruded surface to cut out part of the outside of the ring. 

To extrude the curve 

1 Set the current layer to Layer 01, and 
turn the Default layer off. 

2 Select the curve that defines the interior 
shape. 

3 On the Solid menu, click Extrude Planar 
Curve, and then click Straight. 

4 At the Extrusion Distance … prompt, 
click the BothSides option. 

Set the options as follows: 

BothSides=Yes 
Cap=Yes 
Mode=Straight 
DeleteInput=No 

 

5 At the Extrusion Distance … prompt, in 
the Top viewport, adjust the thickness 
until it is slightly smaller than the height 
of the stones, and click. 
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Cut the Opening in the Top Surface 
We will finish the ring by removing the extruded solid from the ring using a Boolean 
operation. 

To hollow out the ring 

1 Select the ring extrusion. 

2 On the Solid menu, click Difference. 

 

3 At the Select second set of surfaces or 
polysurfaces … prompt, select the 
extruded solid you just created. 

 

 

 


