[bookmark: _GoBack]Oluşturulan veritabanını kullanarak veri girişi yapma işlemine sayısallaştırma denir. Bu işlemde bir önceki konuda oluşturulan Featura Class lara ait hem grafik hem sözel verilerinin girişi yapılacaktır. Daha sonra da bu verileri kullanarak bazı güncelleme fonksiyonları üzerinde durulacaktır.

1. ArcMap’te Veri Girişi
1- ARCGIS_EGITIM\Uygulama_10 klasörü içindeki Uygulama_10 ArcMap proje dosyasına çift tıklayınız. Table of Contents’te Topografya ve Jeoloji raster verilerini göreceksiniz.
2- Standart Tools bardaki Add Data butonunu kullanarak açılan Add Data penceresinde Uygulama_10 > CalismaAlani.mdb > Topografya Feature Dataset içindeki katmanlardan Nirengi, Izohips ve Bitki Feature Class katmanlarını seçerek Add butonuna tıklayınız (Aynı işlem ArcCatalog u kullanarak katmanların ekrana sürüklenmesiyle de yapılabilir). Table of Contents’e 3 katmanın eklendiği görülür. Bunlar 3 farklı geometrik tipe (nokta, çizgi, alan) ait örnekler olup diğer benzer olan katmanların veri girişi aynı şekilde yapılır.
3- [image: ]Standart Toolsbarı ndaki Editor [image: ] butonuna tıklanır ve veri girişi için gerekli olan araç çubuğı aktif hale getirilir.


4- Editor Toolbarı içinde Editor yazısı altında Start Editing sayısallaştırma ve veri girişi için tıklanır.
5- Proje dosyasının sağ tarafında Create Features penceresi açılır (Eğer açılmadı ise Editor Toolbarında en son buton olan Create Features butonuna tıklayınız). Burada Table of Contents’deki nokta, çizgi ve alan katmanları için değişik sayısallaştırma seçenekleri vardır. Hangi katman sayısallaştırılacaksa o katman seçilir, altta açılan Construction Tools dan uygun bir araç seçilerek ekranda sayısallaştırma işlemi yapılır.
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6- Nirengi nokta verisini sayısallaştırmak için öncelikle Tools Toolbardaki Zoom In butonu kullanılarak ekranda nirengi noktasının olduğu alan yakınlaştırılır. Sonra Create Features penceresinde Nirengi katmanı seçilir. Construction Tools dan Point aracına tıklanır. Ekranda yakınlaştırılan nirengi noktası üzerine bir sol mausla tıklanır ve nokta verisi sayısallaştırılır.
7- Sayısallaştırılan nokta verisi seçili konumda iken Editor Toolbarındaki Attributes [image: ] butonuna tıklanır. Açılan Attributes penceresinde seçili olan nirengi nokta verisinin sözel verileri girilir. Bu uygulamada Adi: Kocaçal T., Yükseklik: 381 verisi girilmiştir. Aynı şekilde diğer bütün nirengi noktaları topografya haritası üzerinde Pan ve Zoom In butonları kullanılarak bulunur ve veriler sayısallaştırılır.
Not: Sayısallaştırma esnasında sayısallaştırılan veri altlık haritanın renkleri yanında kayboluyorsa Symbol Selector kullanılarak katmanların sembol ve renk özellikleri değiştirilebilir. Bu sayısallaştırmayı kolaylaştıracaktır.


[image: ]
8- İzohips verisinin sayısallaştırması için öncelikle izohipsi sayısallaştırmaya başlayacağınız bir noktaya ekranda yakınlaşınız. Daha sonra Create Features penceresinde Izohips katmanı üzerine tıklayınız. Altta açılan Contruction Tools da Line aracına tıklayıp ekrandaki izohips üzerinden sayısallaştırmaya başlayınız. Sayısallaştırma esnasında yapılan yanlış ve hatalı çizimler oluştuğunda Standart Tools bardaki Undo butonuna tıklayarak işlemi geri alabilir ve tekrardan kaldığınız yerden devam edebilirsiniz. Çizim işlemi bittiğinde mausa çift tıklayarak sayısallaştırmayı bitiriniz.
9- [image: ]Sayısallaştırılan izohips seçili konumda iken Editor Toolbarındaki Attributes butonuna tıklayıp izohipsin değerini giriniz. Bu uygulamada 100 m izohipsi çizildiği için 100 değeri girilmiştir. İzohipslerin tamamı bu şekilde sayısallaştırılır ve izohips veri tabanı oluşturulur. Diğer çizgi katmanların da sayısallaştırma işlemi aynı şekildedir.

10- Bitki verisini sayısallaştırmak için, sayısallaştırmaya başlanacak alan yakınlaştırılır. Create Features penceresinde Bitki katmanına tıklanır. Altta açılan Construction Tools’da yer alan Polygon aracı seçilerek bitki alanları sayısallaştırmaya başlanır. Sayısallaştırma işlemi bitince çift tıklanarak işlem bitirilir.
11- [image: ]Sayısallaştırılan alan seçili konumda iken Editor Toolbarındaki Attributes butonuna tıklanır ve açılan pencerede bitki Tipi girilir. Bu uygulamada Geniş Yapraklı Ağaç girilmiştir.
Not: Tek bir polygon sayısallaştırıldığında veya ayrık polygon verileri sayısallaştırılırken Construction Tools dan Polygon seçilerek yapılır. Anacak sayısallaştırılan bir polygona komşu polygon ların çizimi için Topoloji kuralları gereği Construction Tools’daki Auto Complete Polygon seçeneği ile sayısallaştırma yapılır. Bu özellikte komşu sınırlar tekrardan çizilmez.
12- [image: ]Girilen bitki türünü çevreleyen bitki türlerini sayısallaştırmak için Construction Tools’dan Auto Complete Polygon seçilir. Daha önce sayısallaştırılan polygonun içerisinden başlamak suretiyle çevresindeki bitki türünün sayısallaştırması yapılır ve sonlandırılırken sayısallaştırılmış bitki türü içinde çift tıklanır. Sayısallaştırılan polygon seçili durumda iken ekranda açık olan Attributes penceresinde bitki tipi girilir. Bu uygulamada Zeytinlik olarak girilmiştir.

[image: ]Not: Bu uygulamadaki gibi Polygon sayısallaştırmada öncelikle genel alan içindeki ayrık polygonlar Construction Tools’daki Polygon seçeneği ile sayısallaştırılır. Daha sonra çevre polygonlar Auto Complete Polygon ile tamamlanır. Bu uygulama şekli ile bitki verisinin tamamı sayısallaştırılır. Topografya ve Jeoloji altlık haritasındaki bazı bilgiler aşağıda verilmiştir. Sayısallaştırma sırasında bu verilerden yararlanınız.
13- Bütün sayısallaştırma işlemleri bittikten sonra Editor altında Stop Editing segmesine tıklayıp sayısallaştırmalarınızı kaydediniz.
[image: ]

2. ArcMap’te Veri Güncelleme
Veri güncelleme, daha önce veri girişi yapılmış katmanlardaki değişiklik ve düzeltme gibi birtakım güncelleme fonksiyonlarını içerir. Veri güncelleme, Editor Toolbarı içindeki fonksiyonlar kullanılarak gerçekleştirilir. Burada çizgi ve polygon katmanlarına ait birtakım güncelleme işlemlerinin uygulaması yapılacaktır.
14- Ugulama_10 ArcMap proje dosyasında Editor altında Start Editing i tıklayınız.
15- Editor Toolbarındaki Edit Tool [image: ] aracını tıklayınız ve daha önce sayısallaştırılan izohipsi seçiniz. Seçilen 100 m izohipsin iki parçada sayısallaştırıldığı ekranda görülür. Bunu ayrıca Izohips katmanı üzerinde sağ maus Open Attribute Table segmesine tıklanarak açılan Table penceresinde de görmek mümkündür.
16- Gerçekte tek parça olması gereken ama iki veya daha fazla kısımdan oluşan katmanlarda bütün parçalar Shift tuşuna basılarak seçilir (Table penceresinde de seçilebilir), daha sonra Editor altında Merge segmesine tıklanarak aynı detaya ait çoklu parçalar tek bir parça haline getirilir.


[image: ]

[image: ]
17- Çizgi katmanlarda bu şekilde bütün çizgileri birden fazla çizgiye bölmek için Editor Toolbarındaki Split [image: ] aracı kullanılır. Örneğin 16. Adımda tek parça haline getirilen izohips seçili durumda iken Split toola tıklanır ve istenen noktadan iki veya daha fazla parçaya bölünebilir. Bölünen çizgi sayısında Attribute Table da satır sayısı artacaktır.
18- Sayısallaştırılan izohips üzerine Zoom In butonu ile yakınlaşınız. Sayısallaştırılan izohipsin bazı kısımlarda tam olarak haritadaki izohips üzerinden geçmediği bazı kaymaların olduğu görülecektir. Bu hatayı düzeltmek için Editor Toolbarındaki Edit Tool [image: ] aracı ile izohipsi seçiniz. Daha sonra Editor’deki Edit Vertices aracına tıklayınız. Ekranda Edit Vertices penceresi ile birlikte sayısallaştırılan izohipsin her bir düğüm noktaları aktif hale gelir.


[image: ]
19- [image: ]Edit Vertices penceresindeki Modify Vertices, Add Vertices ve Delete Vertices butonları kullanılarak sayısallaştırılan izohipsteki hatalar ortadan kaldırılır. Bu işlem polygon katmanları için de aynıdır. Güncelleme işlemi bittikten sonra Editor altında Stop Editing segmesine tıklayıp (Adım 13) güncellemelerinizi kaydediniz.
20- Polygon katmanlardaki güncelleme işlemlerinden Clip ve Cut polygon özellikleri üzerinde durulacaktır. Clip için Editor altında Start Editing i tıklayınız. Sayısallaştırılan bitki alanını yakınlaştırınız. Sayısallaştırılmış kesimde Geniş Yapraklı Ağaçlar küçük adacıklar halinde Zeytinlik’lerin altında kaldığı görülmektedir.


[image: ]
21- Bu bitki türlerini sayısallaştırmak için Creates Features’da yer alan Bitki katmanına tıklanır. Counstraction Tools’da açılan Polygon seçeneği alınarak Geniş Yapraklı Ağaç adacığı çizilir. Sayısallaştırma bitiminde Geniş Yapraklı Ağaç adacığının altında Zeytinlik katmanı mevcut durumdadır.
22- Çizili olan adacık seçili konumda iken Editor altında Clip segmesi tıklanır. Ekrana açılan Clip penceresinde Buffer Distance “0” ve Discard the area that intersect seçeneği de aktif yapılır ve Ok butonuna tıklanır.
23- Clip (kesme) işlemi bittikten sonra seçili olan sayısallaştırılmış bitki adacığının türü Attributes
penceresinde girilir ve bitki türü yazılır (Geniş Yapraklı Ağaç).
[image: ]
24- Cut Polygons (Polygon kesme) aracı ise mevcut polygonu parçalara bölmede kullanılır.
Bunun için öncelikle kesilecek polygon Start Editing konumunda iken Edit Tool ile seçilir.
25- Editor Toolbarındaki Cut Polygons aracına tıklanır, kesimi yapılacak kısımda ilgili polygonun dışından başlanıp kesilecek alanı çizilir ve tekrar polygonun dışında sonlandırılarak alan kesilir.

26- [image: ]Bu kesilen alan önceki veritabanında Zeytinlik olarak tanımlandığı için Attributes butonuna tıklanarak açılan Attributes penceresinde yeni veri girilir (Geniş Yapraklı Ağaç).
27- Yapılan güncellemeleri kaydetmek için Editor altında Stop Editing segmesine tıklayınız (Adım 13).
ArcGIS ile yapılan çalışmalarda veri güncelleme yöntemlerinden birisi de çalışılan alanda arazide toplanan GPS (Global Positioning System) noktalarının, ArcMap ortamına aktarılması ve mevcut verinin bu GPS noktaları baz alınarak güncellenmesini içermektedir. Bunun için öncelikle ArcMap ortamındaki verinizin koordinat sistemi ile aynı olan koordinat sisteminde çalışma alanınızdan toplanmış GPS noktalarına ihtiyaç vardır.
28- Uygulama_10 ArcMap proje dosyası açık konumda iken Standart Toolsbardaki Add Data butonuna kullanarak, Uygulama_10 klasörü içinden Koordinat.xls excel dosyasına çift tıklayınız. Koordinat.xls dosyası içinde açılan sayfalardan Koordinat$ olan sayfayı seçip Add butonuna tıklayınız (normal excel sayfası olup koordinat olarak isimlendirilmiştir).
29- Excel veri grafik veri içermeyip tablo veri olduğu için Table of Contents List by Source konumuna geçecektir. Koordinat$ verisi Table of Contents’te en alt kısma eklenecektir. Koordinat$ verisi üzerinde sağ maus ile Display XY Data segmesini tıklayınız.
30- Açılan Display XY Data penceresinde X Field kısmına X, Y Field Kısmına Y sütunlarının geldiği görülür (Eğer sütun isimleri X ve Y şeklinde excelde hazırlanmamışsa X ve Y ye karşılık gelen sütun isimleri ne ise o isimler seçilir). Koordinat sistemi çalışılan proje dosyasının koordinat sistemi ile aynıdır (Eğer koordinat sistemi gözükmüyorsa Edit butonuna tıklayarak çalışma alanınıza ait koordinat sistemini belirleyiniz). Ok butonuna tıklayınız. Ekranda açılan Object-Id uyarısına Ok deyiniz.
31- Table of Contents’e Koordinat$ Events nokta verisinde excel tablodaki koordinatlar aktarılmış olarak gelir. Bu koordinat verileri kontrol edilir, eğer bir hata yoksa nokta verisini kalıcı olarak bir katmanda tutmak için, Koordinat$ Events üzerinde sağ maus ile Data > Export Data segmesine tıklanır. Ekrana açılan Export Data penceresinde Output konumu ve adı belirlenir. ARCGIS_EGITIM\Uygulama_10\koordinat.shp ve Ok butonuna tıklanarak işlem bitirilir. Veri daha sonra alansal veya çizgi veriye dönüştürülebilir.
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 	VERİ DÖNÜŞÜMLERİ	
ArcGIS, gerek kendi veri formatlarını başka formatlara dönüştürmede gerekse başka yazılımlara ait formatları ArcGIS formatına dönüştürmede birçok olanak sunar. Böylelikle başka yazılım ve formatlarla çalışılan veriler, kolay bir şekilde ArcGIS ortamına aktarılabilmektedir. Ayrıca bu başlık altına noktasal ölçüm değerlerinin excel formatından shapefile formatına dönüştürülmesi de vardır. Ancak bu konu bir önceki başlıkta ArcMap’te Veri Güncelleme bahsinde değinildiği için burada ele alınmamıştır. Bu başlık altında öncelikle ArcGIS kendi veri formatları arası dönüşümler verilecek daha sonra da başka formatlardan ArcGIS formatına dönüşüm üzerinden durulacaktır.
1- ARCGIS_EGITIM\Uygulama_11 klasörü içindeki Uygulama_11 ArcMap proje dosyasına çift tıklayınız.
2- Ankara Frame inde Standart Toolsbar içindeki Add Data butonuyla Uygulama_11 > Ankara klasörü içindeki iki shapefile verisini seçerek Add butonuna tıklayınız. Table of Contents’e Yol_orta ve Binalar katmanları eklenecektir.
3- Aynı alana ve dolayısıyla koordinata sahip bu iki veriyi Geodatabase içine Feature Class olarak dönüştürmek için Standart Toolbardaki ArcToolbox butonuna tıklanır ve ekrana ArcToolbox penceresi açılır. ArcToolbox da, Conversion Tools > To Geodatabase > Feature Class to Geodatabase (multiple) seçeneğine çift tıklanır.
4- [image: ]Ekrana açılan Feature Class to Geodatabase (multiple) penceresinde Input Features seçeneğini kullanarak Yol_Orta ve Binalar katmanı seçilir. Output Geodatabase kısmında browse a tıklanarak Look in kısmına Uygulama_11 klasörü içinde Ankara getirilir. Aynı hizada New File Geodatabase tıklanarak bir geodatabase oluşturulur ve adı Ankara olarak değiştirilir. Ankara.gdb seçili haldeyken Add butonuna sonrada Ok butonuna tıklanır. Dönüşüm gerçekleştirilir.

5- Table of Contents’te yer alan Türkiye Frame i üzerine sağ mausla Activate segmesini tıklayarak aktifleştiriniz. Standart Toolbars daki Add Data butonuyla Uygulama_11 > Turkiye klasöründe Turkiye.mdb içindeki Turkiye_ilMerkez ve Turkiye_il Feature Class verilerini çağırınız.
6- ArcToolbox penceresinde Conversion Tools > To Shapefile > Feature Class to Shapefile (multiple) aracına çift tıklayınız.
7- [image: ]Ekrana açılan Feature Class to Shapefile (multiple) penceresinde Turkiye_ilMerkez ve Turkiye_il Feature Class verilerini seçiniz. Output Folder kısmında browse tıklayınız. Açılan Output Folder penceresinde Uygulama_11 içindeki Turkiye klasörünü tanımlayınız ve Add sonrada Ok butonuna tıklayınız. Feature Class verileri Shapefile verisine dönüşmüştür.
Not: 2-7 arası adımları kullanarak çoklu katman yerine tekli katmanların da dönüşümünü yapabilirsiniz. Ayrıca tekli katmanların bu dönüşümlerini Table of Contents’de katman üzerinde sağ maus Data > Export Data yaparak veri tipini Feature Class veya Shapefile ayarlamak suretiyle yapılabilir.
8- ArcGIS çalışma alanınıza ait Feature Class veya Shapefile verilerinizi .kmz formatına dönüştürüp Google Earth üzerinde görüntüleme imkanı sunar. Bu uygulamada Turkiye Frameindeki Turkiye il katmanı KML verisine dönüştürülüp Google Earth üzerinde görüntülemesi yapılacaktır. Bunun için ArcToolbox penceresi altında Conversion Tools > To KML > Layer To KML aracına çift tıklayınız (Map To KML, .mxd proje dosyanızı bütünüyle kmz verisine dönüştürür).
9- Ekrana açılan Layer to KML penceresinde Layer kısmına Turkiye_il, Output File kısmına kmz verisini kaydedeceğiniz yeri (Uygulama_11\Turkiye\turkiye.kmz) tanımlayınız. Diğer alanlarda bir değişiklik yapmadan Ok butonuna tıklayınız. Böylece Turkiye_il verisi kmz veriye dönüştürülmüştür. Artık Google Earth’te bu veri açılarabilir.
10- Bunun için Google Earth ı çalıştırınız. Dosya altında Aç segmesine tıklayınız. Kmz verisini kaydettiğiniz yerden (Uygulama_11\Turkiye) veriyi çağırınız. Google Earth’e bir katman olarak eklenmiştir.


[image: ]
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11- DWG, DXF ve DGN gibi çok kullanılan CAD formatları ArcGIS’te direkt olarak görüntülenebilmektedir. CAD verilerini ArcGIS veri formatına dönüştürmek için hem ArcMap arayüzü hem ArcToolbox kullanılabilmektedir. Burada sadece ArcToolbox uygulaması gösterilecektir. .dgn uzantılı CAD verisini ArcGIS formatına dönüştürebilmek için ArcToolbox penceresi altında Conversion Tools > To Geodatabase > CAD to Geodatabase çift tıklayınız.
12- Açılan CAD to Geodatabase penceresinde Input CAD Datasets’e Uygulama_11 > DGN klasöründeki 1022.dgn verisini çağırınız.
13- Output Geodatabase kısmına browse ederek Look in kısmında Uygulama_11\DGN klasörünü seçiniz. New File Godatabase butonuna tıklayarak bir gedatabase oluşturup ismini DGN olarak değiştiriniz. DGN.gdb yi seçerek Add butonana tıklayınız.

14- [image: ][image: ]CAD to Geodatabase penceresinde Dataset kısmında bir değişiklik yapmayınız (Veya pafta ismini yazabilirsiniz). Reference scale 1:5000 lik pafta olduğu için 5000 giriniz. Spatial Reference kısmına eğer CAD verisini koordinat sistemi biliniyorsa sağdaki butonu kullanarak koordinat sistemini seçiniz. Bu uygulamada ED_50_TM30 referans sistemi kullanılmıştır. Daha sonra Ok butonuna tıklayınız. Böylece CAD verileri Geodatabase verisine dönüştürülmüştür. Bu veriler çalışma içeriğine bağlı olarak düzenlenebilir.

Not:   ArcGIS  verileri  de  CAD  uzantısına  dönüştürülebilmektedir.  Bu  işlem  ArcToolbax  da Conversion Tools altında To CAD aracıyla yapılır. Ayrıca Table of Contents’te katman üzerinde sağ maus ile Data altında Export to CAD seçeneği ile CAD formatına dönüşüm mümkündür.

Son olarak ArcGIS’deki veri dönüşümleri konusunda Vektör – Raster dönüşümlerinin uygulaması yapılacaktır. Burada sadece polygon vektör verisinin raster veriye dönüşümü gösterilecek olup diğer point ve line vektör verilerinin dönüşümleri aynıdır.
15- Uygulama_11 ArcMap proje dosyası açık konumda iken Ankara Frame ini sağ mausla Activate yapınız. Standart Toolsbarsdaki ArcToolbox butonuna tıklayarak ArcToolbox penceresini açınız.
16- ArcToolbox > Conversion Tools > To Raster > Polygon To Raster segmesine çift tıklayınız.
17- [image: ][image: ]Ekrana açılan Polygon to Raster penceresinde Input Feature kısmına Binalar verisini, Value Field kısmına KAPI_NO yu seçiniz (bunun anlamı, Binalar verisi Raster veriye dönüştürülürken kapı numarasına göre dönüştürülecek demektir). Output Raster Dataset kısmına browse ederek Uygulama_11\Ankara içine bina_raster olarak kaydedileceğini tanımlayınız. Cell Assignment type CELL_CENTER, Priority Field ı NONE olarak deafult ayarda bırakınız. Cellsize ise çalışma içeriğinize veya diğer raster verilerinize bağlı olarak belirleyiniz. Burada 2 olarak girilmiştir ve Ok butonuna tıklayınız. Vektör veri Raster Veriye dönüşmüştür
References:

Hasan Özdemir, Geography Department, Physical Geography Division, Bursa Uludağ University, Bursa, Turkey
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