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1. File Management



Understanding How the Operating System Organizes 
Files, Folders, and Drivers in a Hierarchical Structure
To save any data on the computer, that data must be in a file. 

Storage devices are divided into fixed and removable. While the hard disk is a hard storage 
device, floppy CD, DVD and USB Flash drives are removable storage devices. 

Files are stored in a hierarchical structure within storage devices. Today, hard disks with a 
capacity of terabytes are in use. If we weren't able to store these files in a hierarchical structure, 
we would have to spend most of our time searching for a file. This structure puts the linked files 
in the same folder, creating an easily accessible file structure. 

The physical devices where files and folders can be stored are called drives. Drivers are 
represented by letters in the alphabet. Floppy drives are represented by the letter A or B, and 
hard disks by the letters C and after. CD-ROM and DVD-ROM storage units are represented by 
letters after the hard disk.



Hard disk
The hard disk is the most important storage 
device. 

It contains operating system, program files 
and user files. 

Files stored on the hard disk are not affected 
by power failure. 

Hard disks with very high capacities can be 
produced.



Network drivers
They are very effective in sharing files 
recorded between multiple computers from a 
single central point, online access to files 
recorded from anywhere in the world. 

They connect to the computer system via fast 
Gigabit Ethernet network connectivity and 
USB 2.0 / 3.0. 

They allow for easy storage and sharing of all 
files, photos, videos and music tracks.



USB flash drives
USB flash drives are small, lightweight and 
portable data storage devices that plug into a 
computer's USB port. 

They can be removed and installed during 
operation. 

Faster and easier to use than optical drives.



CD-RW and DVD-RW
CD-RW and DVD-RW are digital optical data 
storage devices. 

They have very large storage capacities. 

A CD-RW can store 700 MB of information, 
while DVD-RW can store 4.7 GB of 
information. 

CD-RW and DVD-RWs are easily affected by 
external factors. Therefore it should be stored 
in a box.



Computer Storage Measures
Computer storage is measured in bytes, kilobytes (KB), megabytes (MB), gigabytes (GB) and
increasingly terabytes (TB). 

One byte is one character of information, and is comprised of eight bits (or eight digital 1's or
0's). 

Technically a kilobyte is 1024 bytes, a megabyte 1024 kilobytes, a gigabyte 1024 megabytes, 
and a terabyte 1024 gigabytes.



Understanding Data Backup and Portable 
Backup Devices
Every data in computer systems should be backed up. In this type of backup, data can be 
transferred online and offline. Data in backups made offline; Data is stored securely by backing 
up with the help of a high-capacity storage unit (hard disk units, multiple storage units (NAS)) or 
optical devices such as CD-RW, DVD-RW drive. In these systems, very high capacities are 
reached. CD-RW and DVD-RW drives are devices that offer much less backup capacity and are 
mostly used for personal backup.

Portable drives are the device that offers the most capacity among portable backup devices. 
They are usually boxes with one or more hard disks, depending on their capacity. They offer data 
storage in very high capacities. USB or FireWire (IEEE 1394) connection standards are used to 
connect these disks to computer systems.



Online Data Storage
Online data storage refers to the practice of 
storing electronic data with a third party service 
accessed via the Internet. It is an alternative to 
traditional local storage (such as disk or tape 
drives) and portable storage (such as optical 
media or flash drives). It can also be called 
"hosted storage," "Internet storage" or "cloud 
storage."

In recent years, the number of vendors offering 
online data storage for both consumers and 
businesses has increased dramatically. Some 
services store only a particular kind of data, such 
as photos, music or backup data, while others 
will allow users to store any type of file. Most of 
these vendors offer a small amount of storage for 
free with additional storage capacity available for 
a fee, usually paid on a monthly or annual basis.



2. Files and Folders



Opening a Window to Find Out the File 
Name, Size and Location
If the mouse cursor is right-clicked on the file 
and the Properties command is selected from 
the popup menu, the window showing the file 
name, size and location opens.



Expanding and Shrinking the Views of 
Drives and Folders
In order to enlarge and shrink the view of the drives and folders, the cursor is placed on the 
outer edge of the opened window, and the left mouse button is held down and dragged until the 
desired view size is reached. 

If the cursor is held from the corners, it is easier to bring the desired size from both width and 
length.



Showing Location of Files and Folders on 
Drive
To view the files in a drive, double click PC 
icon on the desktop. 

In the window that opens, double-click the 
desired drive to list the files and folders in it. 

Folders browsing continues until the searched 
file or folder is found.



Creating Folders and Sub-Folders
You can go to the place where you want to 
create a new folder using Windows Explorer or 
My Computer. The Folder command under the 
New command is selected from the menu that 
opens by right clicking on an empty area. The 
name of the newly created folder is New 
Folder, but it is possible to give the desired 
name. It is possible to create as many new 
folders under any folder. These created folders 
are called subfolders. Thus, files can be stored 
hierarchically on the hard disk and access to 
files is provided more easily.



File Types
In order for information to be stored on the 
computer, it must be in a file. 

Files on the computer consist of two parts as 
<file_name.ext>. The first part is a logical 
name and can be up to 255 characters in total. 
In the filename Characters such as " \ /: *? <> 
|» cannot be used. The second part is usually 
3 characters long. The extension of a file 
indicates with which program the file can be 
opened. 

Some examples of file extensions are listed 
on the side.

Extension File Type

.exe Application file

.txt Text file

.bmp/.jpeg Image file

.doc Microsoft Word file

.xls Microsoft Excel file

.ppt Microsoft Powerpoint file



Opening a Text Editing Application
The most widely used text editing application is Microsoft Word, but a separate fee is required 
to use this editor. 

Although it does not have every feature as MS Word, two text editing applications come with 
Windows at no cost. These are WordPad and Notepad. Of these applications, WordPad offers 
more functionality. 

Both applications are under the All Programs / Windows Accessories folder in the Start menu. 
The text to be typed is entered through the keyboard.



Entering and Saving Text to File
The text to be typed is entered through the 
keyboard. To create a new text file, click the 
New, Ctrl + N icon on the File menu. To open a 
previously saved file, click Open, Ctrl + O icon 
from the File menu. Go to the location where 
the file is located from the Open window and 
click the Open button after selecting the file.

Click Save, Ctrl + S or the floppy icon on the 
Standard toolbar from the File menu to save 
the text file created after the text is entered in 
the file. If the text is to be saved for the first 
time, the Save As window appears. The text is 
stored by entering the location and file name 
of the file to be saved.



Sorting Files
To sort the files in a folder by their name, 
size, type and modification date, right click on 
an empty place in that folder. 

From the menu that opens, under the 
Arrange Symbols command, according to 
which criteria you want to sort, it is selected. 

Another way is to sort by selecting the Place 
Icons command from the View menu.



Rename Files
To change the name of a file or folder, right 
click when the mouse cursor is over the file or 
folder icon. 

The Rename command is selected from the 
menu that opens. 

Another way is to open Windows Explorer, 
left click when the mouse cursor is on the file 
or folder to be renamed, and after a very short 
time a blue box appears around the file when 
left click again. 

Thus the name of the file or folder is 
changed.



Selecting Files That Are Not Adjacent and 
Adjacent Files As A Group
To select a file or folder, use Computer or Windows Explorer to navigate to the location of the 
file. Left click on the icon of the file or folder to be selected. The name of the selected file is 
painted in blue. 

If you want to select more than one adjacent file or folder, the top file is selected while 
Windows Explorer is open. The last file to be selected is selected with Shift + Left click. Thus, all 
files are selected between the first and the last file. 

If you want to select multiple files that are not neighbors, you must use each file + selection, 
Ctrl + Left click combination. Ctrl + A key combination is used to select all files within a folder.



Copying Files and Folders Between Drives 
and Folders
To create a copy of a file or folder on another drive or folder, the files to be copied are selected 
using either Computer or Windows Explorer. 

Copy command is selected from the menu that opens by right clicking on any selected file. 

Again go to the folder to be copied. By right clicking on an empty area of this folder, the 
auxiliary menu is opened. 

A copy of the selected files is created in that folder by selecting the paste command.



Moving Files and Folders Between Drives 
and Folders
If a file or folder is desired to be moved to another drive or folder, the files to be moved are 
selected using either Computer or Windows Explorer. Cut command is selected from the menu 
that opens by right clicking on any selected file. 

Again, using Computer or Windows Explorer, go to the folder to be moved. By right clicking on 
an empty area of this folder, the auxiliary menu is opened. Selecting the paste command will 
move the selected files. 

It should be noted that the files or folders selected as a result of this process will be deleted 
from the first location.



Deleting Files
To delete a file or folder, the file or folder to be deleted is selected 
with a left click and the selected file or folder is sent to the Recycle 
Bin by pressing the Delete key on the keyboard. 

The second way is to choose the Delete command from the menu 
that opens by right clicking on the file or folder. 

If the file deletion was done by mistake, it is possible to restore 
files that are still in the Recycle bin. 

If you want to delete a file or folder without sending it to the 
recycle bin, after the file or folder is selected, the deletion should 
be done with the Shift + Delete key combination. This process is 
irreversible. Should be preferred if you are sure about the deletion 
process.



How to Retrieve Deleted Files and 
Folders from Recycle Bin
A file or folder is inadvertently placed in the 
Recycle Bin

If it was sent, it is possible to restore that file 
or folder. The folder is opened by double 
clicking on the Recycle Bin on the desktop. 
After the file to be restored is found, right click 
on it and choose the Restore command from 
the menu that opens. The file is restored to 
the original deleted location.



Emptying the Recycle Bin
Files sent to the Recycle Bin still take up 
space on our computer's hard drive. If these 
files are not desired to take up space on the 
hard disk, the recycle bin should be emptied 
periodically. 

With the mouse cursor over the recycle bin 
on the desktop, right click and select the 
Empty Recycle Bin command from the window 
that opens. Then a window to confirm the 
action to be performed appears. The Recycle 
Bin will be emptied with the confirmation. 

It should not be forgotten that if the Recycle 
Bin is cleaned, it will never be will not be 
possible.



Finding the Location of Files and Folders 
Using the Search Tool
Thousands of files can be stored on the hard 
drive of a computer. Sometimes we have 
trouble remembering the location of a file we 
created long ago. You can use the search box 
on the Taskbar to find files, folders, programs, 
and e-mail messages stored on your computer.

The search is performed by entering the 
name of the file or folder to be searched in the 
Search Windows line. The search is done 
based on the text in the file name, the 
contents of the file, tags, and other file 
properties.



Extending the Search
If the search for a particular library or folder is not found, it is possible to extend the search 
beyond a particular library or folder to include different locations. 

You can search again with the desired options from the Search menu, which becomes active 
after searching.



Searching Files by Type and First Letter
When searching a file, it is not necessary to know the entire file name. It can also be searched 
using wildcards. "*" is used instead more characters and "?" use instead of a single character. 

You can search by entering * .doc for all Microsoft Word files, * .xls for all Microsoft Excel files, 
e *. * for files starting with the letter e, and ???. * for files whose filename is exactly 3 
characters. 

If searching for a word in a document is desired, the word in the file or should be written in the 
statement section. Search in folder or library

If it is to be made, the storage unit should be selected in which storage unit is desired. In order 
to search by type, it is necessary to know the most used file types.



3. Services



Zip Files
A file or folder can be easily zipped by the use of Compressed 
Folder program of Windows 7

In addition, there are many free  compressed programs that 
you can download from the  Internet. These programs provide 
more capabilities compared to Windows 7 Compressed Folder 
program

A zipped file occupies less space than its actual size in internal 
disk. Therefore, sharing it with anyone takes less time. In 
addition, a zipped folder consisting of more than one file can be 
sent through one e-mail message.

Compressing operation is not useful for image, music and 
video files since this kind of files were already compressed.



Zip Files
To zip a file, open File Explorer from the taskbar. Right-click the file you want to zip, and then 
select Send to > Compressed (zipped) folder. 



Unzip Files
Open File Explorer and find the zipped folder. 

To unzip the entire folder, right-click (or press and hold) it, select Extract All, and then follow 
the instructions. 

To unzip a single file or folder, double-click the zipped folder to open it. Then, drag or copy the 
item from the zipped folder to a new location. 



Protecting Computer
Your computer faces many potential threats, including viruses, malware, and hard drive failure. 
This is why it's important to do everything you can to protect your computer and your files. 



Safeguarding against malware
Malware is any type of software that is designed to damage your computer or gain 
unauthorized access to your personal information. It includes viruses, worms, Trojan horses, 
and spyware. Most malware is distributed over the Internet and is often bundled with other 
software.

The best way to guard against malware is to install antivirus software, such as Bitdefender, 
Norton, or Kaspersky. Antivirus software helps to prevent malware from being installed, and it 
can also remove malware from your computer.

http://www.bitdefender.com/
http://us.norton.com/index.jsp
http://usa.kaspersky.com/products-services/home-computer-security/anti-virus


Run a system scan
Once you've verified that your antivirus program is 
running, begin a scan. If you're unsure how to do 
this, review the documentation for your antivirus 
program, which usually can be found on the 
developer's website. 

Some programs offer several types of scans, and 
you may want to run the most thorough type, 
usually called a full system scan. This may take 
several hours. Usually, you do not need to remain at 
the computer during the scan.



Review discovered threats and 
recommended action
Either during the course of the scan or when it's complete, the antivirus 
program will notify you of discovered threats and recommend various courses of 
action. 

Usually, the recommended action for each threat is the best choice. 

If the antivirus is unable to remove any threat, don't ignore it. Investigate how 
to proceed with some Internet searches or by contacting a professional. The 
support team for the antivirus program can often help you at this point.



Printer Setup



Step-1
Plug in the printer's power cable and make sure it's turned on.



Step-2
Connect the included cable (usually a USB cable) from the printer to the 
computer. Note: The process will be different if you're using a wireless printer



Step-3
On your computer, locate the Printer settings. If you're using a Windows 
computer, you'll find these in the Control Panel. 



Step-4
Look for the option to Add a printer, then follow the instructions that appear.



Step-5
Now it's time to try printing something! 

Firstly, open the file that you want to print

Then, select File > Print from your web browser's menu, or simply press Ctrl+P
on your keyboard (or Command+P if you're on a Mac).



Step-6
A dialog box will appear. Locate and select the new printer from the list, then 
click Print.



View the print queue
To view a list of items waiting to print in Windows 10, go to the search box on the taskbar 
and enter devices and printers. 

Select Devices and Printers and find your printer in the list. 

Right-click on it and select See what’s printing.


