Spreadsheet Program-2




1. Formulas and
Functions




Using cell references instead of entering
numbers in formulas

»Formulas perform calculations or perform other actions on the data in your worksheet. A
formula always begins with an equal sign (=), followed by cell references (such as Al), math
operations.

» For example, the formula = A1 + A2 is used to sum the value in cell A1 and the value in cell A2.




Recognizir

o the standard error values for

formulas:

NAME 7,

DIV /0|,

REF 1.

»#AD in your formula or #NAME?: The most important reason for showing error is a typo in the

formula name.

»># DIV /0! or # DIV /0!: The reason for the error message is to divide a numerical value in a cell
or a numeric value produced as a result of a formula by the number 0 (zero) during arithmetic

operations.

»#REF! or #REF!: The error message occurs when references to a cell are not valid. The cell to
which formulas or functions refer to, or cells may have been deleted or the addresses of the cell
or cells have been changed




Using absolute and bound cell references
in formulas

» A formula with a linked cell reference changes from one cell to another without copying it.

»For example, if you copy the formula = A2 + B2 in cell C2 to C3, the formula references to C3 set
one row down, and it becomes = A3 + B3.

»When you copy this, you can lock the row and column references by placing dollar signs (S)
before them if you want to keep the original cell reference. ”"For example, when you copy the
formula, the formula=SA S 2+ S BS 2 remains exactly the same for C2 and C3. This is the
absolute reference.




Functions

»You can add functions such as sum, minimum, maximum to your worksheet by choosing "Add
Function" from the Formulas tab.

» For example, with the function = SUM (B2: B5), you will find the sum of the cells between B2
and B5.




Using the If function with numeric
operators: =,>, <.

» For example, you can use the If function to determine the pass status of students with a grade
above 70 as Pass, and for students with a grade below 70 as Failed. For this, the formula should
be written in the cell related to Status = IF (F2> = 70; "Pass"; "Failed")




2. Formatting




Setting cells to show decimals, thousands
separators and not

»You can make adjustments to the number of

decimal places for existing numbers in the cell.  wumber mignment  Font  Border  Fil  Protection
To do this, right click on the cell and select Category -
. GEnera | ample
"Format Cells" and set Number and decimal fumbe, 11250
rrrrr oy
plaCGS ‘S‘;’i‘;””tmg Decimal placas:
Time [] use 1000 separator ()
Percentag
Fraction Megative numbers:
Scientific 123410
;Ext_ | 1234.10
ecia 1234.1
Custom E1234|1g]]

Mumber is used for general display of numbers, Currency and Accounting offer specialized
farmatting for monetary value.




Setting cells to show date and money
symbols

Format Cells ? X Format Cells TS
Mumber  Alignment  Font  Border  Fill  Protection Number | Alignment | Font | Border | Fin | Protection |
Category Category
General Sample General - | Sample
Mumber Mumber 5904,732.99
Thursday, June 23, 2016 = 732,
Currency ursday, June =3, urren :
Accountin . ccounting ] . -
| Date Deamalplaces: [2 =
i L Time .
L'E":fmtage “Wednesday, March 14, 2012 A Percentage symbot: |§ =]
Fraction 314 Fraction Megative numbers:
g 31412 Scientific $1 23
Scientific 03/14/12 -51,234.10 -
iy MIMI Text 51,234.10
Special 14-Mar 2 - special (81,234.10
Custom -Mar- Custom [51,234.10)

Locale {location):

English (United States)

Currency formats are used for general monetary values., Use Accounting formats to align

Date formats display date and time serial numbers as date values, Date formats that begin with h ; B
decimal points in a column.

an asterisk [*] respond to changes in regional date and time settings that are specified forthe
operating system. Formats without an asterisk are not affected by operating system settings.

ok | [ Cancel

OK I | Cancel i




Setting the cells so that the numbers
show percentage

>You can show percentages for numbers that | Format Cells
exist in the cell. For this, you need to right click | ["mber | Alamment
on the cell and select "Percentage" from the
"Format Cells" selection.

-!I

Font Border

Category:

General » | Sample
Number 10%
Currency
Accounting

Date

Time

Fraction

Scientific

Text

Spedal

Custom

Decimal places: ’ 0




Cell content view: font sizes, font types

»You need to make the font size settings

for the text in the cell content from the Ty e o R ) (=] ] codrenfomaing (g | 0
. . HE u- A i [; Format as Table = .
"Input" tab "Font Size" option, and the Pte o i [ &e 4 - © e (s BB Cell Styles - el

font settings from the "Font" option. Clipboard & Font 5 Styles .,._




Apply formatting to cell contents: bold,
italic, underline

»You can edit the text in bold, italic,

underhne, by Chang|ng the "Font" "D E."{, [ Calibri - 11‘ :] = % EZ Conditional Formatting ~ 8 ol
settings on the "Home" tab for the paste E ’ i TI ;:.;‘ A Alignment. Number gzl";:;ztable' Cells_ Editing
Styles -

format settings for text in the cell Clipboard 15 Font
content.




Apply different background colors to cell
content and background

»You need to change the "Fill Color"

setting in the "Font" field in the "Home" s gs G -[1_ || | =| || 95| | FEiConditionalFormatting~ || gy ||| p
t bt | b k d | t th Paste 8- B I U-|A A Alignment Mumber 5 Format as Table - Cells  Editing
ab to apply a background color to the g _E_, " ™% 5 Cell Styles~ lls | B
cell contents. Ciipboard 15 e Styles -

L]
HE EEETEEW

Standard Colors
| B | FfEEEERN
Mo Fill

#.1 Meore Colors...




Copying a format from one cell to
another

»To copy a format from one cell to another,
you must use the "Format Painter" on the

"Home" tab. "D db Cut Calibri - |1
E@ Copy -

Paste S
- * Format Painter B I U —

Clipboard ] Font




Apply the Wrap Text option to the text in
the cell

»The "Wrap Text" option on the "Home" tab
should be used to adjust the text in the cell to
fit the column width.




Aligning cell contents

»You can align the text in the cell right, center,
or right using the "Align" options on the
"Home" tab.

Farmulas Data Review View Developer

== - EF"WFEPTEH‘I:

4
p J B Copy -
aste - | NE €= 3=
= ~ Format Painter . U = O - -& - .MEFQE&CE”EF

Clipboard Fa Font Alignment




Combining cells under a title

When you merge two or more adjacent
horizontal or vertical cells, the cells are
converted into a single large cell displayag
multiple columns or rows. For this ope
the "Merge and Center" option in the '

Farmulas Data Review View Developer

alls C ) r | = ==
tab ShOUld be Used. D EECUt Arial -la A A == F- =¢ Wrap Text
) Dp}r - e ] o
Pﬂfte ~ Format Painter B I U- - O- A | S = = | =3 [ METQE&'-CE”EF]

Clipboard Fa Font I Alignment




Adding a frame effect to cells: lines,
colors

»You can quickly add a frame around cells or a
range of cells using predefined border styles.
To do this, first select the cells and then use
the Borders option on the Home tab.

ata
: ria -4 A A = S = Wra
paste = oPY T
aste B I U- A === EE B
= ~ Format Painter = -& = == | == MEFQE&CEHter
P Font [

Alignment




3. Charts




Creating different charts from worksheet

data

» After selecting the data you want to create a
chart, you can choose from the chart types
from the insert tab: column, bar, line and pie
chart.

-
Insert Chart

itk

AR 4p o8 08 44

| Recommen ded Charts | All Charts |
& Recent
Templates "_HI_I_‘
Ikl Column

|2 Line Stacked Column




Choosing a chart

»To select the chart, simply click on it.

»When you make a selection, you will be able to see the Design and Layout settings related to
the graphic on the tabs.




Changing Chart Type

When you select the graphic, in order to Change CratType L E ]
change its type, the "Change Graphic Type" ETTP‘“‘-‘S B =
option should be used in the "Design" tab. e oo | (] [=f) (B8] 5| &3] 98| 83 |

& Fie — S S — S o o

- | (o) J08] B |da| Jsd] JA4

hm :t\;c[kScatter) M m M M M

@ Surfac Line

e || e e e

W Radar Pie

O © o O @ @ !
[manageTempbates...] [ Set as Default chan] | ok ][ Cancel




Move, resize and delete the graphic

» After selecting the chart, you can move it by dragging and dropping.

» After selecting the graphic, you can resize it by dragging the sizing handles to the desired size.

»To delete a graphic, right click on the graphic and select "Delete".




Add, remove and edit chart titles

»When you want to add a title to your chart,
select "Chart Title" from the options under
"Add graphic" in the "Design" tab while the
graphic is selected.

»To remove the title, right click the title and
select “Delete”.

» For title-related edits, double click on the title
text.

FILE HOME

1L o

Add Chart Cuick
Element = Layout ~

R EBREERE®BHES

=

Axiz Titles
Chart Title
Data Labels
Data Table
Error Bars
Gridlines

Legend

Trendline

T

IMSERT

PAGE LAYOUT

Change
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More Title Options...




Adding data labels to the chart

»When you want to add data labels to your Q IDJ A “@ |u£| ||,_,.j|

n n H
chart, ?'eleCt Data I:Iabels fll:om .the"OpthnS. ture Shapes Text Chart Axiz Legend} Data
under "Add graphic" in the "Design" tab while v _Box | [Title- Titles~ -
. . Inserf] —— MNone
the graphlc IS SeIeCted' A "|r'i Turn off Data Labels for i
selection =
i — Center

-',' 24| Display Data Labels and position
centered on the data point(s)

— Inside End m
=1/1| Display Data Labels and position |4
inside the end of data point(s)
—1 Inside Base |
| Display Data Labels and position
inside the base of data point(s)
——1 Outside End

"|r|]' Display Data Labels and position
outside the end of data point(s)

More Data Label Options...




Change the background color of the
graphics area
»To change the background color of the

graphics area, the color of the "Shape Fill" m

must be changed from the "Format" tab while | Zsshaperil-

the graphic is selected. Automatic
Theme Colors
B EEENRTEN

L
|||I||||I|

Standard Colors

[l fEEEEn
No Fill i}

%* More Fill Colors.. |

[asl Picture.,
[l Gradient »
Fl Texture »




Changing bar, line, column colors in chart

»In order to change the color of bar, line and column in the chart, "Change Colors" should be
used from the "Design" tab while the chart is selected.




Changing the font size, color and text of
the chart

»Select the text area you want to make changes in the graphic and use the "Font" field in the
"Home" tab.




4. Preparing for Print




Change worksheet margins

»To change the boundaries of the worksheet,
you can update the values of the top, bottom,
nght and left margins by C“cking the ”Margins” File Home Insert Page Layout Formulas Data Revig

icon in the “Page Layout” tab. E C-:-h:urs' { ] =0 [%, =
M

H S o -

argins |Orientation  5ize  Print  Breaks Background

Page Setup




Change the orientation of the worksheet
and page size

»To change the orientation of the worksheet,
select the "Orientation" icon from the "Page
Layout" tab’ and you can set the page File Home Insert Page Layout Formulas Data Revie

vertically or horizontally. T ¥ = |
v v o o _{Pﬁ ID}E’%h
argin

>F0r page Size Settings, make the appropriate The:nes Eﬁzectsv Orientation  Size | Print Breaks Background

H S o -

-

Area~

selection from the "Size" menu. Themes Fage Setup




Adjusting the structure of the content of
the worksheet

After selecting "Header and Footer" from the = 2- =
«Insert» tab, you must select the "Page
Number" feature.

File Home Insert Page Layout Farmulas

. %E“@“

Header Footer Page Mumber Current Current File File

& & Mumber of Pages Date Time Path Name
Header & Footer Header & Footer Elements
A2 o Page Number N

Add the page number to the header
| orfooter.
| : E|




Adding, editing, deleting subtitles, top
titles to the worksheet

After selecting "Header and Footer" from the «Insert» tab, you can add, edit or delete a title.




Check and correct spreadsheet
calculations and text

Before printing, you should check the calculations and text in the spreadsheet and correct any
incorrect appearance.




Showing and hiding row and column
lines while printing

Data Review View

If you want the row and column lines to QG Home Insert  Pagelayout  Formulas
appear in the printout, select the Gridlines-
Print option in the Page Layout tab. Deselect
this if you don't want it to appear.

S222 ‘ D l@{ :é /| Ruler Formula Bar q l:

Normal| Page Page Break Custom Full V] Gridlines Headings Zoom I
Layout Preview Views Screen

Workbook Views ‘ Show ‘ z




Auto add title row to worksheet when
outputting

|f you wa nt the t|t|e |ine to appear on the File Home  Insert  Page Layout Formulas Data Review | View _
printout, choose Headings-Print on the Page
Layout tab.

3=

S222 ‘ D f IEJ :;j V| Ruler Formula Bar Q l:

Normal| Page Page Break Custom Full V] Gridlines Headings Zoom I
Layout Preview Views Screen

Workbook Views } Show ‘ z




Preview the worksheet

Select the worksheet (s) you want to preview.
Click "File" and then click Print to view the
preview window and print options.

Account

Options

Print

=

Print

Printer

Ready

HP Laserlet P3011/P30153 PC..

Settings

Printer Properties
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Print Selection
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Selecting a range of cells in the worksheet,
determining the number of copies

When you want to output a specific range of o Print
cells in the worksheet, select "Print" from the

_ : o [core ]
File tab after selecting that cell range, then = [
select "Print Selection from Settings". o
Printer
HP Laserlet P3011/P3015 PL...
% Ready . ”

Printer Properties

Settings
E| Print Selection .
Only print the current selecti...
Pages: | :| to | -
—  Collated
|_|E||E| 1,23 123 123

D Portrait Orientation

|:| Ad
21 cmx 29.7 cm

MNarmal Margins

Left 1.78cm Right 1.78 cm ’
[B[ Mo Scaling
Dmﬂ Print sheets at their actual size
Page Setup




