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Introduction 
 
Why SPSS 
After the experiment is run and the data are collected, you the biologist face the 
task of converting numbers into assertions; you must find a way to choose 
among your hypotheses the one closest to the truth. Statistical tests are the 
preferred way to do this, and software programs like SPSS make performing 
these tests much easier. 
  
SPSS is a powerful program which provides many ways to rapidly examine data 
and test scientific hunches. SPSS can produce basic descriptive statistics, such 
as averages and frequencies, as well as advanced tests such as time-series 
analysis and multivariate analysis. The program also is capable of producing 
high-quality graphs and tables. Knowing how to make the program work for you 
now will make future work in independent research projects and beyond much 
easier and more sophisticated. 
 
What this guide is 
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This document is a quick reference to SPSS for biology students at Barnard 
College. The focus is on using the program, as well as laying the foundation for 
the statistical concepts which will be addressed.  
 
How to use this guide 
Much of the information in this guide is contained in the help files and tutorial 
which are in the SPSS program. We strongly recommend that you at least glance 
at the tutorial, which shows you how to do all the essential tasks in SPSS. You 
can find it in the "Help" menu, under "Tutorial". Throughout this document, we will 
simply write, for example, Help > Tutorial to tell you where to find a certain action 
or file; the first name will always be a selection from the menu bar at the top of 
the screen.  
 
The core content for how to do a given statistical test is given in each section. 
Many additional details are listed in the Graphing and Finer Points sections. 
Details about all of the real data sets used to illustrate the capacities of SPSS are 
in the Data Appendix. 
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Basics 
This section describes the essentials of how to start using SPSS to manage and 
explore your data effectively. If you have previously used a spreadsheet program 
like Microsoft Excel, many features of SPSS will be familiar. However, even if you 
have never used any quantitative program before, the essential features of SPSS 
are easy to learn with a little patience. 

Starting SPSS 

Go to the Applications folder, and select SPSS from the list of programs (or Start 
> Programs > SPSS, on a PC). A window will appear, asking you what to do. 
There are several options, but you will often want to import data from Excel. In 
that case, you would go to "Open another type of file", select "More files…" and 
navigate to the Excel file you want to use. 
 
To just open it up for the first time, click "Type in data" and select "OK". 
 

 
 

Navigating 

SPSS uses several windows to manage data, output, graphs, and advanced 
programming. You will use two windows for everything you need in this class: the 
Data Editor and the SPSS Viewer. 
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Data Editor 

The Data Editor window displays the contents of the working dataset. It is 
arranged in a spreadsheet format that contains variables in columns and cases in 
rows. There are two sheets in the window. The Data View is the sheet that is 
visible when you first open the Data Editor and contains the data. This is where 
most of your work will be done. 
 
Unlike most spreadsheets, the Data Editor can only have one dataset open at a 
time. However, you can open multiple Data Editors at one time, each of which 
contains a separate dataset. Datasets that are currently open are called “working 
datasets” and all data manipulations, statistical functions, and other SPSS 
procedures operate on these datasets. The Data Editor contains several menu 
items that are useful for performing various operations on your data. Here is the 
Data Editor, containing an example dataset. 
 

 
 
Notice that there are two tabs on the bottom, Data View and Variable View. Data 
View is typically the working view, and shows the data just as an Excel 
worksheet does.  
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For example, in the above window, "SITE" is defined to be what SPSS calls a 
"string", or simply a set of characters with no numerical value. All the others are 
and defined to be a continuous numerical variable, with two decimal points 
shown. Strings are called a categorical variables, in contrast to continuous 
numeric variables (more on this in Fine-tuning the data). It is not essential to use 
the Variable View, and we will mostly ignore it for now. 
 

SPSS Viewer 

 
All output from statistical analyses and graphs is printed to the SPSS Viewer 
window. This window is useful because it is a single place to find all the work that 
you have done – so if you try something new, and it doesn't work out, you can 
easily go back and see what your previous work was.  
 

 



Guide to SPSS       Barnard College – Biological Sciences 

  7 

 
The left frame of the SPSS Viewer lists the objects contained in the window. In 
the window above, two kinds of descriptive statistics summaries were done, and 
these are labeled Frequencies and Descriptives.  
 
Everything under each header, for example Descriptives¸ refers to objects 
associated with it. The Title object refers to the bold title Descriptives in the 
output, while the highlighted icon labeled Descriptive Statistics refers to the table 
containing descriptive statistics (like the range, mean, standard deviation, and 
other useful values). The Notes icon would take you to any notes that appeared 
between the title and the table, and where warnings would appear if SPSS felt 
like something had gone wrong in the analysis.  
 
This outline is most useful for navigating around when you have large amounts of 
output, as can easily happen when you try new tricks with SPSS. By clicking on 
an icon, you can move to the location of the output represented by that icon in 
the SPSS Viewer; a red arrow appears on both sides of the frame to tell you 
exactly what you are looking at.  
 

Getting your data in 

Opening an Excel file 

Importing data into SPSS from Microsoft Excel and other applications is relatively 
painless. We will start with an Excel workbook which has data we later use for 
several of our example analyses. These data are the IQ and brain size of several 
pairs of twins, with additional variables for body size and related measures. 
There are 10 pairs of twins, five male and five female. 
 

 
 

It is important that each variable is in only one column. It might seem to make 
sense to divide the data into male and female, and have separate columns for 
each. However, working with SPSS will be much easier if you get used to this 
format: one row, one individual. 
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First, go to the Data Appendix and download the file IQ_Brain_Size.xls 
("Relationship between IQ and Brain Size"). This will be the first step for all the 
examples in this Guide. Open SPSS and select "Type in data". To open an Excel 
file, select File > Open > Data from the menu in the Data Editor window. 
 

 
 

First, select the desired location on disk using the Look in option. Next, select 
Excel from the Files of type drop-down menu. If you don't do this, it will only look 
for files with the .sav extension, which is the SPSS format. The file you saved 
should now appear in the main box in the Open File dialog box.  
 

 
 

You will see one more dialog box: 
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This dialog box allows you to select a worksheet from within the Excel Workbook. 
You can only select one sheet from this menu; if you want both sheets, you need 
to import the second sheet into another Data Editor window.  
 
This box also gives you the option of reading variable names from the Excel 
Workbook directly into SPSS. Click on the Read variable names box to read in 
the first row of your spreadsheet as the variable names. It is good practice to put 
your variable names in the first row of your spreadsheet; SPSS might also 
change them slightly to put them in a format it likes, but they will be basically 
what you entered in your Excel file. You should now see data in the Data Editor 
window. Check to make sure that all variables and cases were read correctly; the 
Data Editor should look exactly like your Excel file.  
 

 

Manually entering data 

If you only have a few data points, or simply like typing lots of numbers, you can 
manually enter data into the Data Editor window. Open a blank Data Editor as 
explained above, and enter in the data in columns as necessary.  
 
To name your variables (which are always in columns in the Data View), double-
click the grey heading square at the top of each column, which will be named var 
until you change them. When you do this, the Data Editor will switch to the 
Variable View; now each variable is in one row (not column). Enter the name in 
the first column. You can also add a "label" to each variable, giving a longer 
explanation of what the data are; see Fine-tuning the data for more on this.  
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Opening an existing SPSS file 

 
If you have already saved your work (see below) or are sharing a file with a 
partner, you can open the existing file in two ways. Either choose the file when 
first opening SPSS by choosing “Open an existing data source”, or while already 
in SPSS, go to File > Open > Data… and choose the appropriate file.  
 

Saving your work 

 
As mentioned above, SPSS works with different windows for different tasks; you 
will use the Data Editor to manage your data, and the SPSS Viewer to examine 
the results of analyses and create graphs (much more on this below). So you 
also need to save each window separately. This will be clear when you go to File 
> Save in either window; the first time you save each window you will be asked to 
name the file and choose where to save it. 
 
The file extension (the letters at the end of the file name, like .doc for Word files 
or .xls for Excel) are different for these two file types. Data Editor files are saved 
as .sav, while output files (from the SPSS Viewer) are saved as .spo. Remember 
that when you are sharing your work with your partner – make sure to give him or 
her both files. 
 
Remember that SPSS produces more output than you really need to present for 
almost every analysis. It is worthwhile to spend a little time trimming unnecessary 
information from the output when preparing a lab report or paper. This will make 
it easier for the reader to understand what you want to communicate with your 
table or graph. You can read more about how to trim down the output in Model 
output. 

Cutting and pasting 

Output in the SPSS Viewer can also be cut and pasted into Word or Excel files, 
with all the formatting preserved. This is useful when you want to prepare a lab 
report (or paper) and want to insert a graph or table. Simply right-click an object, 
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select “Copy”, and then paste into your report. You can also right-click the name 
of an object in the left-hand pane of the SPSS Viewer (or even several objects) 
and do the same. 
 
Sometimes when pasting a graph, SPSS crops the image in unexpected ways. If 
this happens to you, try exporting the output instead. The next section tells you 
how to do this. 

Exporting 

If you want to save all the graphs and tables in one file, go to the SPSS Viewer 
and select File > Export. The window below will pop up, and ask you to choose 
where to save it (“Browse…”). Make sure to remember where you save it – the 
default location is unfortunately buried in the hard drive, so choose a readily 
accessible location (like the desktop or the Documents folder). 
 
You also need to tell SPSS what type of file to save it as. You will usually want to 
select “All Visible Objects” and export it as a Word/RTF (.doc) file. This is the 
easiest way to save all your work in useful format (RTF is Rich Text Format, 
which can be read in nearly any text application on any platform).  
 

 
 

You can also get to this dialog by clicking the Export button  on the menu 
bar. 
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Describing data 
 
The first task when beginning any analysis is to simply look at the data. One of 
the best ways to do this is to create a histogram, which is a graph that shows 
the measured value on the x-axis and how many observations of each value on 
the y-axis. This is also known as a frequency distribution, because it shows you 
the distribution of the frequency of occurrence for the values. In addition, we want 
to know the summary statistics, like means and standard deviations. These are 
the essential steps in single sample estimation. 

Frequency distributions 

 
Histograms, bar plots of the data grouped by frequency of observation, are 
excellent first summaries of the data. These figures show us immediately what 
the most frequent values are, and also which values are least frequent; this is 
what is meant by a frequency distribution.  
 
In addition, you can get a sense of where the center of the data is (the mean), 
and how much variance there is around that center. In statistical terms, these are 
called measures of central tendency and dispersion, or "location and spread". 
Also, we can easily see if there are any truly bizarre numbers, as sometimes 
happens when a measurement error is made; outliers can then be examined 
closely to see if they are real values or just mistakes.  
 

You can produce histograms for any continuous variable. A continuous variable 
is a value like body length or number of individuals which might vary continuously 
from zero to very large (or go negative, or be fractional). A variable like sex is 
considered categorical, since you would use only one of two categories, female 
or male, to describe a given case.  
 

Note: 

What SPSS calls Scale variables can be either ratio or interval variables in 
the terminology of Portney & Watkins (2000).  
 
These are Continuous variables, since data values represent quantitative 
differences. Categorical variables simply place the data in different 
categories. These should be coded as "Nominal" in SPSS. 

 

SPSS Portney & Watkins This Guide 

Scale Ratio, interval Continuous 

Nominal Nominal Categorical 

Ordinal Ordinal Ordinal 

 
Other ways of viewing frequency distributions include frequency polygons and 
stem-and-leaf plots. Frequency polygons are essentially line plot representations 
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of histograms, while stem-and-leaf plots are numerical representations, showing 
which integer values fall within the larger 'bins' of numbers.  

In SPSS 

 
Begin by opening the file OldFaithful.xls in SPSS. These data show the date and 
time of every eruption of the geyser Old Faithful in Yellowstone National Park for 
one month. For each eruption, several variables were recorded, including the 
interval since the last eruption and the duration of the eruption (see the Data 
Appendix for more information). 
 
View your data in the Data Editor, in the Data View. Note that the duration values 
have many decimal values; we can clean this up. Change the view to the 
Variable View, and reduce the number of decimals shown for the "Duration" 
variable. 
 

 
 
 
Return to the Data View, and select Analyze > Descriptive Statistics > 
Frequencies as in the image below. 
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Next, select the measurement that you want to analyze. Note that different 
variable types will have different icons identifying them. In the example below, 
the variable Interval has already been double-clicked. 
 

 
 
To produce the histogram, click “Charts…” and then select “Histograms” in the 
window that pops up. Check "With normal curve". 
 

 
 
Select “Continue” and “OK”, and then examine the results in the SPSS Viewer. 
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Again, notice that the red arrow in the left pane indicates where in the output you 
are looking. Note that the black line, representing a normal distribution, does not 
represent the data well at all. This has important consequences for how we 
choose to proceed.   
 

Parametric vs. Non-parametric statistics 

 
Statistical tests are used to analyze some aspect of a sample. In practice, we 
want the results of the test to be generalizable to the population from which that 
sample was drawn; in other words, we want the sample to represent the 
parameters of the population. When we know that the sample meets this 
requirement, we can use parametric statistics. These are the first choice for a 
researcher. The use of parametric statistics requires that the sample data: 

 Be normally distributed 

 Have homogeneity of variance 

 Be continuous 
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These assumptions are explained below. If the sample data seriously violate 
these requirements, then it is safer to use non-parametric statistics, which are 
tests of data which make fewer assumptions. Such tests also have reduced 
ability to detect significant differences, so should be used only when necessary. 
Throughout this guide, we will present the non-parametric alternatives to the 
standard parametric tests. 

Normality 

The concept of normality is central to statistics. For data to be normal, they must 
have the form of a bell curve, or Gaussian, distribution, with values dropping off 
in a particular fashion as they increase or decrease from the mean. Specifically, 
a normal distribution contains 68.26% of the data within ±1 standard deviation 
from the mean.  

Homogeneity of Variance 

For parametric statistics to work optimally, the variance of the data must be the 
same throughout the data set. This is known as homogeneity of variance, and 
the opposite condition is known as heteroscedasticity. 
 

In SPSS 

Both normality and homogeneity of variance can be assessed through the 
Explore tool in SPSS: Analyze > Descriptives > Explore. Select the Interval 
variable as the dependent, and Accurate as the factor. See the Data Appendix 
for a full description of these data.  
 
In the Plots options window, select Histogram, Normality plots with tests, and 
Untransformed. These are explained below. 
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Look at the results in the Output Viewer. The Explore tool produces a full set of 
descriptive statistics by default; this is an alternative to the Descriptives tool 
explained above. Note that in the "Yes" category for accuracy, the median value 
of geyser eruption interval is very close to the mean; there is little skew in the 
data. When this is the case, it is usually reasonable to assume that the data are 
normally distributed, but here we have tested that assumption directly. 
 
SPSS calculates two statistics for testing normality, Komogorov-Smirnov and 
Shapiro-Wilk. 
 

 
 

Note: SPSS reports highly significant values as ".000", which should be 

read and reported as "<0.001". 

 
Kolmogorov-Smirnov D test is a test of normality for large samples. This test is 
similar to a chi-square test for goodness-of-fit, testing to see if the observed data 
fit a normal distribution. If the results are significant, then the null hypothesis of 
no difference between the observed data distribution and a normal distribution is 
rejected. Simply put, a value less than 0.05 indicates that the data are non-
normal. 
 
Shapiro-Wilks W test is considered by some authors to be the best test of 
normality (Zar 1999). Shapiro-Wilks W is limited to "small" data sets up to n = 
2000. Like the Kolmogorov-Smirnov test, a significant result indicates non-normal 
data.  
 

Both of these test indicate that both categories of results (ones for which the 
predicted of eruption time was accurate and those not) the sample data are not 
normally distributed. On this basis alone, it may be more appropriate to choose 
non-parametric tests of the hypotheses. 
 
In addition to the normality tests, we chose to test the homogeneity of variance in 
this sample. You can only do this when you have groups to compare; this 
requires some categorical variable.  
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There are several tests for homogeneity of variance; SPSS uses the Levene 
Test. Some statisticians (Zar 1999) propose that Bartlett's test for homogeneity is 
superior, particularly when the underlying distribution can be assumed to be near 
normal, but SPSS has no packaged Bartlett test.  
 
There are several statistics reported here; the most conservative one is the 
"Based on Median" statistic. Since the Levene's Test is highly significant (the 
value under "Sig." is less than 0.05), the two variances are significantly different, 
and this provides a strong warning against using a parametric test. 
 

Note 

Because parametric tests are fairly robust to violations of 
homoscedasticity, it is generally recommended to use parametric tests 
unless the above tests for normality and homogeneity show strong 
departures, 
Or 

If your data are all nominal or ordinal, you can only use non-parametric 
tests. 
 
In order to focus on only the assumption of normality, ignoring the 
homogeneity of variances assumption, repeat this procedure without a 
factor variable. 
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Data Analysis 
 
Investigating the patterns and trends in the data is the core feature of SPSS. This 
section describes four groups of tasks that you will have to be able to complete 
over the course of this lab. Only the fundamental concepts and steps are 
presented here; for more detail on the statistics or program details, refer to your 
text or ask an instructor. 

Analyzing Frequencies: Chi-square 

 - Additional Topics: Transforming continuous variables to categorical 

 
In order to asses the relationship between two categorical variables, use a chi 

square (2) test. A chi square test is a widely-used non-parametric test, which 
examines if the frequency distribution of the observed data matches that of either 
the expected data or another known distribution. A typical question for this type 
of test is whether there is an association between two categorical variables.  
 
Open up the file Kidney.xls in SPSS. By default, when this file is read in all 
variables are assumed to be "scale", or continuous, data. In fact, several of them 
are categorical variables, and you must manually change them in the Variable 
View tab of the Data Editor. See the Data Appendix for details. This following 
process is an example of how to manipulate data variables. 
 

 
 
First, change the "Measure" of the Sex variable to Nominal. Then click on the 
"Values" cell for this variable, and enter 1 for the first value, and "Male" for the 
first value label; do the same for females. 
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Similarly, the numerical values in the DiseaseType variable represent different 
diseases; enter in the value labels accordingly. 
 

 
 
Save this file in an appropriate location as Kidney.sav; these codes will be saved 
for future use.  
 
Now we can test the degree of association between these two categorical 
variables: is the frequency of these kidney diseases significantly associated with 
sex? We will use the "Crosstabluation" method in SPSS for this example. Go to 
Analyze > Descriptive Statistics > Crosstabs… 
 
In the Crosstabs window, select DiseaseType as the row variable and Sex as the 
column.  
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Then click the Statistics… button and select Chi-square. Note that many other 
statistics of association are available, most of which are described in Portney & 
Watkins (2000).  

 

 
 

Finally, click the Cells… button. In the following window add the Counts: 
Expected, Percentages: Row, and Residuals: Standardized options (add the 
Column and Total percentages to make the resulting table directly comparable 
with that in Portney & Watkins).  
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The results, in the Output Viewer, break down the observed and expected 
frequencies ("Count") for each sex and disease type. We can look at the 
frequency values within sex to visually estimate how much the observed differs 
from the expected, and then examine the result of the chi square test. This 
shows that there is no significant association between kidney disease type and 
sex (p = 0.255; highlighted in blue below).  
 
 DiseaseType * Sex Crosstabulation 

 

 Sex Total 

  Male Female   

DiseaseType Glomerulo 
nephritis 

Count 
6 12 18 

    Expected Count 4.7 13.3 18.0 

    % within DiseaseType 33.3% 66.7% 100.0% 

    Std. Residual .6 -.3   

  Acute nephritis Count 4 20 24 

    Expected Count 6.3 17.7 24.0 

    % within DiseaseType 16.7% 83.3% 100.0% 

    Std. Residual -.9 .6   

  Polycistic 
kidney disease 

Count 
4 4 8 

    Expected Count 2.1 5.9 8.0 

    % within DiseaseType 50.0% 50.0% 100.0% 

    Std. Residual 1.3 -.8   

  Other Count 6 20 26 

    Expected Count 6.8 19.2 26.0 

    % within DiseaseType 23.1% 76.9% 100.0% 
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    Std. Residual -.3 .2   

Total Count 20 56 76 

  Expected Count 20.0 56.0 76.0 

  % within DiseaseType 26.3% 73.7% 100.0% 

 
 

Chi-Square Tests 

 
 

Value df 
Asymp. Sig. 

(2-sided) 

Pearson Chi-Square 4.064(a) 3 .255 

Likelihood Ratio 3.880 3 .275 
Linear-by-Linear 
Association 

.053 1 .818 

N of Valid Cases 
76     

 
a  2 cells (25.0%) have expected count less than 5. The minimum expected count is 2.11. 

 

Note: Chi square tests are also found in Analyze > Nonparametric Tests > 
Chi square… 
This method is easier to use for simpler tests, such as testing observed 
data against a uniform distribution. 

 
An additional question we could ask is whether patient age and disease type are 
associated. Currently age is a continuous variable, and we could analyze it as 
such. But a simpler approach would be to convert ("Transform", in SPSS) this 
variable as categorical, and take advantage of the robust and easy-to-interpret 
chi square test. 
 
In the menu bar, choose Transform > Visual Bander…; in the resulting window 
choose Age as the variable to band. Here "banding" refers to dividing a 
continuous variable into categories. 
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In the Visual Bander window, click Age, and name the new variable to be created 
as AgeBand. Select "Excluded" for Upper Endpoints, and choose Make 
Cutpoints… 
 

 
 
There are several possible ways to divide the data with "cutpoints". An easy way 
to make four categories which contain equal numbers of cases is to choose 
Equal Percentiles based on Scanned Cases. Choose 3 cutpoints and select 
Apply. 
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Finally, choose Make Labels back in the Visual Bander. This will create value 
labels, similar to what we did manually for sex and disease type. 

 

 
 
After clicking OK, a message window will appear, letting you know that one new 
variable ("AgeBand") will be created. 
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Now we will assess the independence of age and disease type using a Chi-

square test. To quickly return to the Crosstabs menu, click the icon and 
select Crosstab. Replace the Sex variable with our new AgeBand variable in 
columns; all the other options will be the same as we specified before. Click Ok 
and look at the results in the Output Viewer. 
 
There is a highly significant association between age and disease type (p < 
0.001). Looking at the standardized residuals (highlighted below), this appears to 
be largely driven by the Other category, which was much more frequent in 
younger patients than expected by chance, and much less frequent in older 
patients.  
 

 Age (Banded) Total 

 DiseaseType <34 34 - 45 46 - 53 54+   

Glomerulo nephritis Count 2 2 10 4 18 

    Expected Count 4.3 4.7 4.3 4.7 18.0 

    % within 
DiseaseType 

11.1% 11.1% 55.6% 22.2% 100.0% 

    Std. Residual -1.1 -1.3 2.8 -.3   

  
Acute nephritis 

Count 
0 10 4 10 24 

    Expected Count 5.7 6.3 5.7 6.3 24.0 

    % within 
DiseaseType 

.0% 41.7% 16.7% 41.7% 100.0% 

    Std. Residual -2.4 1.5 -.7 1.5   

  
Polycistic kidney 
disease 

Count 
0 0 4 4 8 

    Expected Count 1.9 2.1 1.9 2.1 8.0 

    % within 
DiseaseType 

.0% .0% 50.0% 50.0% 100.0% 

    Std. Residual -1.4 -1.5 1.5 1.3   

  
Other 

Count 
16 8 0 2 26 

    Expected Count 6.2 6.8 6.2 6.8 26.0 

    % within 
DiseaseType 

61.5% 30.8% .0% 7.7% 100.0% 

    Std. Residual 4.0 .4 -2.5 -1.9   

Total Count 18 20 18 20 76 

  Expected Count 18.0 20.0 18.0 20.0 76.0 

  % within 
DiseaseType 

23.7% 26.3% 23.7% 26.3% 100.0% 
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Comparing two groups 

T-tests 

We use t-tests to compare the means of two groups. A t-test looks at the two 
distributions (as we did above) and determines whether or not their means are 
significantly different. The null hypothesis in a t-test is that there is no significant 
difference between the two means.  
 
For this test, we will answer the question: for common trees in the Northeast, are 
leaf photosynthesis rates different over the course of the year? Open the file 
Leafgas.xls. In the Variable View, code the species names, by double-clicking 
the corresponding Values cell and entering the full names. 
 

 
 
Go to Analyze > Compare Means > Independent-Samples T Test.  Place Month 
in the Grouping Variable and Photosyn in the Test Variable boxes. Note that 
Month is followed by (?, ?). Even though there are only two months of data in this 
example, July and September, SPSS requires you to manually enter in the codes 
for the two groups when running a t-test. Click Define Groups… to do so. 
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Here type in the names of the months, to be used as the two independent groups 
of data. 

 

 
 
 
When examining the results in the Output Viewer, note that SPSS in fact runs 
two tests whenever conducting a t-test. The first examines whether or not the 
variance around both means is the same; this is the same homogeneity of 
variance test encountered in the Descriptive Statistics section. If the variances 
are the same, we should use a standard t-test (“Equal variances assumed”). If 
not, we use a corrected test (“Equal variances not assumed”). How do you know 
which one to use? Look at the fourth column, “Sig.” under Levene’s Test for 
Equality of Variances. If this value is greater than 0.10, then you can assume that 
the variances are equal. 

 
 
Since in this case the variances are clearly not equal (p < 0.001), we want to use 
the version of the t-test which does not assume equal variances. In this case, 
there is a highly significant difference between leaf gas exchange in July and 
September (p < 0.001).  
 
This table can be modified (see Working with Tables for details) to make it easier 
to read. 
 
Making graphs of the two groups helps to convey these results quickly to your 
reader, as well as helping you interpret the results; see Bar charts and Box plots 
in the Graphing section. 
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Paired T-tests 

When the investigator takes two or more measurements under different 
conditions with the same subjects, and then wishes to perform a t-test to 
understand the effects of different conditions, the correct test to use is a paired t-
test. In this classic example, rates of tooth decay were measured in 16 cities 
before and after the fluoridation of the municipal water supply. The alternative 
hypothesis being tested here is that fluoridation causes changes in the rates of 
tooth decay. Open the data file Fluoride.xls in SPSS to see what this looks like. 
 
Note that what requires the investigator to use a paired t-test and not a typical 
(independent samples) t-test is that the same subjects were used more than 
once. For example, a given city may have had particularly low tooth decay rates 
to start with, so it is important to look at the changes for that particular city, not 
the before and after groups as a whole. Using a paired t-test allows the 
investigator to identify the effects of the treatments in spite of effects unique to 
certain individuals. 
 
To begin, you would place the seasons in separate columns, and each row must 
have both measurements for a single individual test subject. Because you have 
two columns that are different measurements of one dependent variable, this is 
rather different from a typical t-test. For a typical t-test, a dependent variable is 
placed in its own column, and the groups or treatments (here before and after) 
would be specified in a categorical column titled “Treatment”. 
 
To conduct this test, go to Analyze > Compare Means > Paired-samples T Test. 
In the dialog box select both Before and After, then click the arrow to move them 
over to the right side, as shown below. Then click “OK.” 
 

 
 
The results show that the mean pair-wise difference of -12.21% is significant (p = 
0.003).  

Paired Samples Test 
 

  Paired Differences t df 
Sig.  

(2-tailed) 
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  Mean 
Std. 

Deviation 

Std. 
Error 
Mean 

95% Confidence 
Interval of the 

Difference       

        Lower Upper       

Pair 
1 

BEFORE - 
AFTER 

-12.212 13.616 3.4040 -19.468 -4.957 -3.588 15 .003 

 

Comparing two groups – Non-parametric 

Two independent groups: Mann-Whitney U 

When the assumptions of normality are not met for a two-group comparison, 
there are powerful non-parametric alternatives. For independent (unpaired) 
groups which are non-normally distributed, the appropriate test is called the 
Mann-Whitney U test.  
 
First, open up the Cloud.xls example file. These data show results of cloud-
seeding experiments; we want to know if releasing silver nitrate into the 
atmosphere from a plane increases rainfall. These data are highly skewed; verify 
this using the Explore procedure. In the Variable View, code the Treatment 
values as 0: Unseeded and 1: Seeded. 
 

 
Then go to Analyze > Nonparametric Tests > Two-Independent-Samples Tests. 
Place Treatment as the Grouping Variable, and Rainfall as Test Variable.  
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As with the t-test, you have to manually assign the groups for the test. Here they 
are simply "0" and "1" for unseeded and seeded. 

 

 
 
Recall that nearly all nonparametric tests are based on ranking the data, and 
then examining how the sums of the ranks differ between groups. The first table 
shows the ranks for these cloud-seeding data. 
 
 

Ranks 
 

  Treatment N Mean Rank 
Sum of 
Ranks 

Rainfall Unseeded 26 21.31 554.00 

  Seeded 26 31.69 824.00 

  Total 52     

 

The second table is a summary of three different test statistics; here focus on the 
first and last rows, the Mann-Whitney U statistic and the significance. Cloud 
seeding increases rainfall (p = 0.013). 
 

Test Statistics(a) 
 

  Rainfall 

Mann-Whitney U 203.000 

Wilcoxon W 554.000 

Z -2.471 
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Asymp. Sig. (2-tailed) .013 

a  Grouping Variable: Treatment 

Paired groups: Wilcoxon Signed Rank Test 

 
Similarly, for paired research designs there also exist powerful nonparametric 
tests. Return to the fluoride example. If you used the Explore tool to assess how 
these data are distributed, you would find that the rates of tooth decay before 
fluoride treatment are non-normally distributed (Shapiro-Wilk, p = 0.029). 
Therefore, a more conservative approach would be to use the Wilcoxon Signed 
Rank Test, the nonparametric alternative to a paired t-test. 
 
Go to Analyze > Nonparametric Tests > 2 Related Samples, select both Before 
and After, and move them into the test pairs list. 
  

 
Note that in the results, SPSS organizes the variables alphabetically, so 
calculates the difference from After to Before. Therefore, the "Positive Ranks" are 
have a much greater sum than the negative ones. Here, "positive" means that 
the rates of tooth decay were higher before treatment than after. 
 

Ranks 
 

  N Mean Rank 
Sum of 
Ranks 

AFTER - BEFORE Negative Ranks 4(a) 3.63 14.50 

Positive Ranks 12(b) 10.13 121.50 

Ties 0(c)     

Total 16     

a  AFTER < BEFORE 
b  AFTER > BEFORE 
c  AFTER = BEFORE 
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Looking at the test statistic summary, we see that this difference is significant (p 
= 0.006). 

Test Statistics(b) 
 

  

AFTER - 
BEFORE 

Z -2.767(a) 

Asymp. Sig. (2-tailed) .006 

a  Based on negative ranks. 
b  Wilcoxon Signed Ranks Test 
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Testing associations between continuous variables 

Correlation 

To what extent are two variables related? We examined this question for 
categorical variables using chi square tests previously, and now address 
continuous variables. These tests examine how two variables change together, 
without addressing questions of causality.  

Parametric: Pearson correlation coefficient 

Also known as the Pearson product-moment correlation, or r, this statistic is the 
standard measure of association between two independent, normally distributed 
variables.  
 
We will look at how to use this test using data on bird diversity surveys in oak 
forests in California. Open Birds.xls from the Data Appendix, and go to Analyze > 
Correlate > Bivariate. Here the tool is called "Bivariate", but in fact it is possible to 
put in more than two variables. 
 
Place the species richness and population density variables in the Variables box. 
Here we will look at the strength of association between these two measures of 
bird communities, without asking whether one causes the other. Leave "Pearson" 
checked, and click OK. 
 

 
 

The results show that there is a strong, positive, and significant relationship 
between the number of bird species in a community and the total number of 
breeding pairs (r = 0.507, p = 0.01). This is partially because there must be more 
individuals to have more species, but suggests that there may be an interesting 
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story behind what causes population density and number of species to change in 
sync.  
 

Correlations 
 

  No. Species 
Total 

density 

No. Species Pearson Correlation 1 .507(**) 

Sig. (2-tailed)   .001 

N 40 40 

Total density Pearson Correlation .507(**) 1 

Sig. (2-tailed) .001   

N 40 40 

**  Correlation is significant at the 0.01 level (2-tailed). 
 

When we graph these data, the strong positive association is clear. Graphic 
representations of data make your job of convincing the reader much easier, by 
showing how the two variables change together. 
 

 
 
This chart was created and modified using these steps. 

Nonparametric: Spearman's rho 

In cases where the distribution of the data is highly skewed, violating the 
assumption of normality, you should not use the Pearson correlation coefficient. 
In this same data set, two environmental variables are highly non-normally 
distributed, Elevation and Latitude. You can check this using the Explore tool. 
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Here we are not asking any question about the biology of this system, but simply 
whether the data collection process tended to choose sites where elevation and 
latitude are correlated. In a well-designed study, these should be independent. 
 
Open the Bivariate Correlations dialog box again (remember you can do it quickly 

with the Dialog Recall  icon), and place these two in the Variables box. 
Choose Spearman, and unselect Pearson. 
 

 
 
Surprisingly, and unfortunately for these researchers, there is a strong, negative, 
significant relationship between elevation and latitude (rs = -0.615, p < 0.001). 
This means that any general conclusions drawn from this study need to be 
tempered by the knowledge that elevation and latitude are not independent; the 
sites sampled higher up on the coast (more north, higher latitude) were generally 
at lower elevations than those sampled further down the coast.  
 
 Correlations 
 

  Elevation Latitude 

Spearman's rho Elevation Correlation Coefficient 1.000 -.615(**) 

Sig. (2-tailed) . .000 

N 29 29 

Latitude Correlation Coefficient -.615(**) 1.000 

Sig. (2-tailed) .000 . 

N 29 40 

**  Correlation is significant at the 0.01 level (2-tailed). 
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Regression 

When our question centers on answering if one variable predicts another, 
regression is the key statistical tool, not correlation.  For example, does ozone 
concentration in a given city predict how many children develop asthma, or does 
height predict average annual income in corporate America?  
 
We address such questions with linear regressions, which test for the presence 
of straight-line relationships between the predictor variable and the response 
variable. Other shapes of relationships are possible, and in fact common in 
biology, but we will start with linear regression. 
 
In the following example, we examine whether vegetation density predicts the 
density of breeding bird populations in California forests. A significant positive 
relationship would indicate that birds seek out dense vegetation for breeding, 
while a negative relationship would indicate that less dense vegetation is 
preferred, perhaps because ease of access to food resources. Open Birds.xls (or 
if you saved if from the correlation example, Birds.sav), and go to Analyze > 
Regression > Linear. 
 
Choose which variable will be your predictor (Independent) and which will be the 
predicted (Dependent). Note you should only use continuous variables for this 
analysis. To be able to identify individual points easily, place SITE in the Case 
Labels box.  
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SPSS produces more output than necessary to report when writing your results, 
but it is all useful. There are two values that you want to look at and make sure to 
put in your lab report. The first is the R2

 (written "R Square" in the output). This is 
the correlation coefficient, otherwise known as the goodness of fit for your 
statistical model. Unlike for P-values, there is no critical value for R2, you just 
have to report it and let the reader decide. Here the R2 is 0.225, meaning 22.5% 
of the variance in bird population density is explained by the change in vegetation 
density. For an ecological study, this would be considered an important effect.   
 
 

Model Summary(b) 
 

Model R R Square 
Adjusted R 

Square 
Std. Error of 
the Estimate 

1 .474(a) .225 .197 3.549 

a  Predictors: (Constant), Profile Area 
b  Dependent Variable: Total density 

 
 
 ANOVA(b) 
 

Model   
Sum of 
Squares df Mean Square 

F 

Sig. 

1 Regression 102.174 1 102.174 8.111 .008(a) 

  Residual 352.707 28 12.597     

  Total 454.881 29       

a  Predictors: (Constant), Profile Area 
b  Dependent Variable: Total density 

 
 
 Coefficients(a) 
 

Model 
  Unstandardized Coefficients 

Standardized 
Coefficients  

   B Std. Error Beta t 

Sig. 

1 (Constant) 3.022 2.883   1.048 .303 

  Profile Area .230 .081 .474 2.848 .008 

a  Dependent Variable: Total density 
 

 
The other value to look is again a p value of the predictor. Here we want to look 
at the P-value for the slope of the regression line. The equation for a straight line 
is y = a + bx. The independent variable is x, the dependent variable is y, a is the 
intercept, and b is the slope. Regression analysis figures out what the best 
values of a and b are, and reports these as coefficients. It then tests whether the 
coefficient b, the slope, is different from zero.  
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A slope of zero means that the dependent variable changes arbitrarily as the 
independent variable changes. However, just because the slope is different from 
zero doesn’t mean that the relationship is necessarily any good – that's why we 
also look at the R2. Here the p value for Profile Area is 0.008, which is significant. 
Furthermore, the slope is 0.23, indicating that for every unit increase in 
vegetation density, bird population density increases by 0.23.  
 
The middle table, labeled ANOVA, presents another view of how good this model 
is at explaining the data. If we had tried more than one model, the ANOVA 
procedure would let us pick out the best model. Also note here that the ratio of 
the sums of squares of the model to the total sums of squares is the calculation 
for R2: 102.17 / 454.88 = 0.225. 
 
Once you do the regression, you will also want to make a graph to see what the 
relationship looks like, and to make sure that the assumptions of normal 
distributions hold up. See Scatter plots below for how to add the regression line. 
 

 
 

Note: There is such a thing as nonparametric regression, which is 

available in SPSS through the Curve Estimation tool. This is appropriate 
when you are specifically testing a particular nonlinear relationship, or 
know that you cannot assume that the variables have normally-distributed 
error terms. 
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Comparing Multiple Groups - Parametric 

One-Way Analysis of Variance (ANOVA) 

 -  Additional Topics: Post-hoc tests (Multiple comparison test) 

The third major type of analysis you will want to know how to do is Analysis of 
Variance, or just "ANOVA". Just as t-tests are useful for asking whether the 
means of two groups are different, ANOVA can answer the question of whether 
the means of many groups differ from each other. Biologists find these useful 
because we often design experiments with many treatments (like different drugs), 
and then want to know whether some variable (like proliferation of cancer cells) is 
different between the groups. 
 
In this example, we will consider a data set of low birth weight births from the 
Center for Disease Control, which are categorized by region and the tobacco use 
status of the mother. This is clearly not a manipulative experiment, but we can 
still apply statistical tools using the observed data.  
 
Open Natality.xls, and add the region names and tobacco use code names in the 
Values boxes (in the Variable View). Save this as Natality.sav. To begin the 
ANOVA, go to Analyze > Compare Means > One-way ANOVA.  
 

Note: The explanatory variable (Region in this case) has to be in numeric, 

not string format for SPSS to run an ANOVA. This means you may need 
to go into the Variable View as described below and make sure that the 
variable type is numeric. Use values like 1, 2, 3… for the different groups. 
You can then create labels in the Values box to make the results easier to 
interpret.  
 
Also note that the Explore tool should be used to examine the 
assumptions of normality and homogeneity of variance before proceeding. 

 

 
 
Select the variable you want to look at and put it in the Dependent List. You can 
choose more than one – for example, if we also measured leaf thickness for 
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these plants, we could place that in the Dependent List as well. The Factor is 
your independent variable, which will define the groups to compare.  

 
 
 

Note: There is only one variable allowed in the Factor box; this is what is 

meant by a "one-way" ANOVA, since we are looking at how a single 
categorical variable explains the variance in a continuous variable. 

 
The SPSS output for ANOVA is fairly concise. Again, there is really one value 
which answers our question, and again it is a P-value. The last column of the 
ANOVA table is the significance value; if it is below 0.05, then we say we have 
rejected the null hypothesis of no difference between the group means, and that 
there is a significant difference.  
 ANOVA 
 
Percentage Low Weight Births  

  
Sum of 
Squares df Mean Square F Sig. 

Between Groups 9.241 3 3.080 9.046 .000 

Within Groups 31.327 92 .341     

Total 40.568 95       

 

 
Surprisingly, there is a highly significant effect of region on the rate of low birth 
weight births, accounting for nearly 25% of the variance in these births. Look the 
sums of squares to understand the variance; the between groups variance is 
compared to the within groups variance to calculate the significance of the test, 
hence "analysis of variance".  
 
To look a bit deeper, create a plot of the values using Graphs > Bar > Simple, 
with Region Code as the Category Axis and the mean of the percentage of low 
birth weights as the bar height.  
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It seems that the rate of low weight births in the West is much lower than the 
other regions; now we will test this hunch specifically. 
 
In order to do this, we go through the steps to re-do the ANOVA. Only this time, 
in the "One-way ANOVA" window select the “Post Hoc” button. Post hoc means 
“after this” in Latin, and refers to tests we do after the fact to see how, knowing 
that the main effect is significant, each treatment level relates to the others. If the 
main effect is not significant, post hoc tests are not useful.  
 
In the post hoc window, select Tukey (for Tukey's honestly significant difference, 
HSD) and click “Continue” and then “OK”.  Notice that there are lots of different 
tests we could choose from, and they may give you different answers; Portney & 
Watkins consider LSD and Duncan "too liberal", for example. Zar (1999) also 
promotes the Tukey test for multiple comparisons (both for parametric and 
nonparametric ANOVAs). Portney & Watkins also discuss the merits of the 
Scheffé post-hoc test.  
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The resulting table takes some time to interpret. First, notice that the first column 
is one category, and then the second column has all the other categories 
corresponding to it. This means we first start with one "treatment", Northeast, and 
then compare its mean to the means of the three other regions. Notice, for 
example, that the difference between Northeast and Midwest is the same as the 
difference between the Midwest and Northeast, only with the sign reversed. 
 

Multiple Comparisons 
 
Dependent Variable: Percentage Low Weight Births  
Tukey HSD  

(I) Region Code (J) Region Code 

Mean 
Difference (I-

J) Std. Error Sig. 

95% Confidence 
Interval 

Lower 
Bound 

Upper 
Bound 

Northeast Midwest 0.227 0.168 0.534 -0.213 0.668 
  South 

0.050 0.168 0.991 -0.391 0.491 
  West 

.781(*) 0.168 0.000 0.341 1.223 
Midwest Northeast 

-0.227 0.168 0.534 -0.668 0.213 
  South 

-0.178 0.168 0.718 -0.618 0.263 
  West .554(*) 0.168 0.008 0.114 0.995 
South Northeast 

-0.050 0.168 0.991 -0.491 0.391 
  Midwest 

0.178 0.168 0.718 -0.263 0.618 
  West 

.731(*) 0.168 0.000 0.291 1.173 
West Northeast 

-.781(*) 0.168 0.000 -1.223 -0.341 
  Midwest -.554(*) 0.168 0.008 -0.995 -0.114 
  South 

-.731(*) 0.168 0.000 -1.173 -0.291 
*  The mean difference is significant at the .05 level. 
 

Pay attention to is the asterix mark (*) next to the mean difference. If it is there, 
then we know that this difference is significant. Here, the west has significantly 
lower rates of low weight births than all three other regions, and they are not 
significantly different from each other. This quantifies our hunch from the bar 
graph. Why this difference comes about would require further study. 
 

Note: If your table has cells filled with “*******”, this means that there are 

too many digits for SPSS to display. You can double-click the chart to 
make it editable, and then drag columns wider to make the values visible. 

 
 
 

Analysis of Variance with Multiple Factors 
 - Additional Topics: Fixed vs. Random effects, clustered bar graphs 
 

The example above describes how to conduct an ANOVA in SPSS that looks at 
the influence of only one factor ("one-way ANOVA"). But what about when you 
are interested in the effects of two or more factors on the response variable? For 
instance, in this example. A two-factor analysis of variance does not merely run 
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two one-way ANOVAs, but can test how the two factors interact, meaning how 
does the change in one of the predictors determine the change in the dependent 
variable, given the change in the other predictor.  
 
We will return to the birth weight data set, and now ask three questions of the 
data:  

1. Between 1995 and 2002 in the US, did the number of children born at low 
birth weights differ between regions? 

2. Did the cigarette smoking status of the mother significantly affect the 
proportion of low birth weight births? 

3. Is there any interaction between these two predictor variables? 
 
First re-open Natality.sav (with the region codes and tobacco use codes). In 
SPSS, two-way ANOVAs are considered just one version of what is known as a 
"General Linear Model" (see Portney & Watkins, p. 450). Select to Analyze > 
General Linear Model > Univariate. As demonstrated below, put your dependent 
variable in the “Dependent Variable” space, in this case Percentage Low Weight 
Births.  
 
Your independent variables are called slightly different names from what we are 
used to. Here, a "Fixed Factor" is an independent variable which is set by the 
experimenter in some way, like a drug concentration or species grouping. You 
should only consider a predictor as fixed factor if all of the possible values of that 
variable are represented in the data. A "Random Factor" is a predictor variable 
which was not set by the experimenter, and whose values represent a sample 
from a larger population. Both geographic region and tobacco use can be 
considered fixed factors for this analysis. 
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Before continuing, set several of the options. First, select Post Hoc and choose 
Tukey for both variables.  
 

 
 
Then, in the Plots dialog, choose a RegionCode x TobaccoUseCode profile plot 
as below. Click "Add" after adding the variables to the axis and lines boxes. 

 



Guide to SPSS       Barnard College – Biological Sciences 

  46 

 
 

The output lists each factor listed, and then reports the interactions between the 
factors. An interaction is labeled with an "*" between the factors whose 
interaction is being tested. Here, both of the main factors are by themselves 
highly significant, but the interaction is not (although see the note below). This 
means that tobacco use does not affect birth weight differently in one region than 
in the others. 

 
 
 Tests of Between-Subjects Effects 
 
Dependent Variable: Percentage Low Weight Births  

Source 
Type III Sum of 

Squares df Mean Square F Sig. 

Corrected Model 20.808(a) 11 1.892 8.041 .000 

Intercept 286.783 1 286.783 1219.117 .000 

TobaccoUseCode 8.783 2 4.391 18.668 .000 

RegionCode 9.241 3 3.080 13.094 .000 

TobaccoUseCode * 
RegionCode 2.784 6 .464 1.973 .079 

Error 19.760 84 .235     

Total 327.351 96       

Corrected Total 40.568 95       

a  R Squared = .513 (Adjusted R Squared = .449) 
 

We also chose to make a "profile plot" of these results. This shows that the mean 
percentage of low weight births from mothers of "Unknown" smoking status in the 
West is quite low, much lower than the other regions. While there was no 
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significant interaction between the predictor terms, this crossing of lines is exactly 
what an interaction test aims to reveal.  

 
 

Note: Some investigators in biology will report p-values between 0.1 and 

0.05 as "marginally significant". This implies that they view the chance of 
detecting a result as extreme as the one observed only 1 in 10 times by 
chance alone as important. The use of "marginally significant" varies 
between journals, and you might be better off simply reporting the p-
values without such commentary. 

 
We can refine our interpretation of these results with better graphs. First, make a 
graph to see the effects of both main factors, using a clustered bar chart. Go to 
Graphs > Bar, and choose Clustered in the dialog box. 

 



Guide to SPSS       Barnard College – Biological Sciences 

  48 

 
Place mean percentage low weight births in the Bars Represent box, and 
tobacco use and region in either of the Category Axis and Define Clusters By 
boxes. 

 

 
 

In the Options dialog, choose error bars representing 1 standard error of the 
mean. 
 
The resulting graph shows the data in an alternative format. This shows that the 
variability in the Unknown category is quite large within each region, except for 
the West, where the mean and the variability are low. We now might wonder why 
the data are so different for the western region, and might begin to suspect that 
this represents a systematic difference in the way the data were collected, not 
necessarily a truly different pattern of tobacco use in the western states. 
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Finally, we can show these data in panels, using the Interactive graphing feature, 
described in detail the Graphing section. 

 
 
For another example of repeated measures ANOVA, following Portney & 
Watkins, see below. 
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Comparing multiple groups – Nonparametric 

One-Way: Kruksal-Wallis 

 
As before, when the assumptions of normality are not met by the data, the typical 
parametric tests lose power. In such situations, non-parametric tests are not only 
more justifiable on theoretical grounds, but are more likely to identify the 
underlying factors structuring the data. In comparing the means of multiple 
groups, the Kruksal-Wallis test is the analog of a one-way ANOVA. It is also 
called a "distribution-free ANOVA", since it is "free" of any assumptions about 
how the data are distributed (Devore 2004). 
 
This test is a variation of the Mann-Whitey U test for two groups, where all the 
data are ranked, and then the distribution of ranks is compared against a uniform 
distribution, using a chi-square test.  
 
Return to the low-birth weight data set, Natality.xls (or Natality.sav, if you saved it 
as an SPSS file). In this example, we examined how regions of the US differ with 
respect to the percentage of children born at low birth weights, using data from 
the CDC. We proceeded with a one-way ANOVA, but if we test the assumptions 
of normality, using the Explore tool, we find that the distributions are non-normal, 
and the variances are unequal (not shown). Thus a non-parametric test is the 
conservative option. 
 
 Tests of Normality 
 

   Kolmogorov-Smirnov(a) Shapiro-Wilk 

 Region Code Statistic df Sig. Statistic df Sig. 

Percentage Low 
Weight Births 

Northeast 
.289 24 .000 .724 24 .000 

  Midwest .254 24 .000 .779 24 .000 

  South .217 24 .005 .865 24 .004 

  West .254 24 .000 .854 24 .003 

a  Lilliefors Significance Correction 
 

Go to Analyze > Nonparametric Tests > K Independent Samples. Here, "K" 
refers to K number of groups, a naming convention in statistics for a number of 
categories in a factor variable. 
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Place Percentage Low Weight Births in the Test Variable List and Region Code 
in the Grouping Variable. The (? ?) following Region Code indicates that SPSS 
needs your direction about which group values to use in this test. Click Define 
Range and place 1 in the minimum and 4 in the maximum value boxes. 
 

 
 
The output of the Kruksal-Wallis test first shows the table of ranks, which shows 
that the values in the West region have a much lower mean rank than the others.  
 

Ranks 
 

  Region Code N Mean Rank 

Percentage Low 
Weight Births 

Northeast 
24 57.04 

  Midwest 24 48.96 

  South 24 67.58 

  West 24 20.42 

  Total 96   

 

This result is highly significant (p < 0.001). Note that there are k-1 degrees of 
freedom; with k = 4 groups, there are three degrees of freedom. 
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Test Statistics(a,b) 
 

  

Percentage 
Low Weight 

Births 

Chi-Square 37.918 

df 3 

Asymp. Sig. .000 

a  Kruskal Wallis Test 
b  Grouping Variable: Region Code 

 

Two-Way: Friedman 

Nonparametric alternatives to for two-factor analyses of variance have been 
generally described by some statistical authorities as "unsatisfactory", particularly 
since the parametric tests are relatively robust to violations of the assumptions of 
normality (Zar 1999). 
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Repeated-measures ANOVA 

- Additional Topic: Sphericity 
Also known as within-subjects design, these tests are used when each subject is 
measured multiple times. Different treatments may applied to each subject over 
time, or to groups of subjects in a uniform way. Similar to paired t-tests, these 
tests increase the power of the analysis by accounting for the idiosyncratic 
differences between subjects.  
 
The following conditions make a study appropriate for repeated-measures 
ANOVA: 

 Several measurements taken on each subject over time 

 Distinct treatments applied either to each subject at different times or to 
groups of subjects at a single time or throughout the study 

 More than two time points 

 One or more continuous response variables 
  

Questions which might be suitable for this type of analysis include: Does an 
experimental diet lead to better test performance of two groups of study animals? 
Which medium leads to the most proliferation in several cell lines over time? Do 
subjects improve their balance over time when given a sequence of experimental 
treatments? 
 
Here we will use a real data set to ask whether different concentrations of a tree 
bark extract lead to different survival rates of termites. These data can be used to 
see if the tree bark compound would be suitable for development as an anti-
termite treatment. 
 
Open Termites.xls (see the Data Appendix). This study has a "mixed design" or 
"two-way design with one repeated measure" in the terminology of Portney & 
Watkins, with two treatment levels applied to different blocks of subjects, and 
many measurements in time for each subject. 
 
Go to Analyze > General Linear Models > Repeated Measures. The first dialog 
requires you to "define factors". Here we need to make a name two new objects, 
the Within-Subject Factor Name, which you can name by what is actually being 
assessed at each measure. In this case, it is the number of termites surviving. 
There are 13 measures in our data set (they skipped days 3 and 9). Second, you 
need to type in the Measure Name. This should just be the time units for the 
repeated measures, which in this case is day. Type in each, making sure to click 
"Add", then choose Define. 
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The next dialog shows all the 13 levels of the "survival" factor, named as "day". 
We want to match these up with the 13 columns of measurements we have. 
Select day1 to day15, and click the arrorw to move them into the Within-Subjects 
box. Then move dose into the Between-Subjects Factors box. 

 
 
It should now look like this: 
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In this example, we only have two doses. If we had more levels in this factor, we 
would want to examine the differences between each category using the Post 
Hoc dialog (Tukey).  
 
To create a graph of the results, click Plots. Move dose (or whatever between-
subjects factor you have) into the Seperarte Lines box, and survival into the 
Horizontal Axis box. 
 

 



Guide to SPSS       Barnard College – Biological Sciences 

  56 

Finally, choose Options, and at least click the Estimates of effect size and 
Homogeneity tests boxes. 
 

 
Choose Continue, and then OK to run the test. 
 
Before looking at the results, it is necessary to digress briefly to discuss the 
concept of sphericity. 
 
Sphericity 
In other parametric tests, we have been concerned with the normal distribution of 
data and homogeneity of variances. In a repeated-measures design, we are also 
concerned with equal correlations between the data at different time points; this 
is known in statistics as sphericity. This assumption considers the covariance 
between measurements.  
 
If the sphericity assumption is violated, the chance of a Type I error (incorrectly 
rejecting the null hypothesis of no difference between groups) increases. This is 
a troubling outcome, and unfortunately difficult to resolve. 
 
Alternatives include multivariate analyses of variance (MANOVA), which do not 
require sphericity. SPSS runs a MANOVA by default for a repeated-measures 
ANOVA, with the results in the Multivariate Tests table. There is rarely any major 
difference between them in terms of significance values, but if necessary to 
choose the appropriate test, consult a specialized text on multivariate statistics 
(e.g., Manly 2005). 
 
SPSS performs two tests related to sphericity, Box's Test for Equality of 
Covariance Matrices and Mauchly's Test of Sphericity. Portney & Watkins 
provide a succinct description of Mauchly's test (p. 447).  
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If the result of the Mauchly test is significant (p ≤ 0.05), there is a significant 
violation of the assumption of sphericity. Therefore, we should correct the 
degrees of freedom when performing the ANOVA; SPSS does this automatically 
and notes it in a footnote beneath the Mauchly test table. The correction is called 
epsilon. 
 
SPSS reports all possible significance values, using the different epsilon 
corrections. Here are the meanings of each of these: 
 

 Sphericity Assumed: Original degrees of freedom, assuming that the 
covariance matrix shows equal covaraince between the independent 
factors. 

 

 Greenhouse-Geiser:  Degrees of freedom adjusted conservatively. If the 
uncorrected effect is significant but the Greenhouse-Geiser corrected 
effect is not, check the next line, Huynh-Feldt. 

 

 Huynh-Feldt: Degrees of freedom adjusted. If the G-G corrected effect is 
not significant, and neither is the Huynh-Feldt, then you cannot reject the 
null hypothesis.  

 

 Lower-bound: Degrees of freedom adjusted very conservatively. Only use 
this in cases when it would be extremely risky to make a Type I error 
(incorrectly reject the null hypothesis). However, because it is so 
conservative, it is likely to lead to Type II errors (incorrectly fail to reject 
the null hypothesis). 

 
Returning to the model results, we first see the multivariate analysis of variance 
tests. These test the effect of the within-subject factor, survival, as if each 
measurement were a different variable; that is what makes this a multivariate 
test. The different flavors of MANOVA are all identical here, showing a significant 
effect of the day measured; this is not interesting or surprising, since we expect 
that termites will start dying off in the petri dishes quite naturally. 
 
However, the next set of values, survival x dose, show no effect. This indicates 
that the survival of termites did not differ depending on the concentration of tree 
bark extract. This indicates that the tree bark extract would not be useful as an 
anti-termite treatment. But this result should be treated very cautiously, since the 
multivariate test is less powerful than a repeated-measure ANOVA.  

 
Multivariate Tests(b) 

 

Effect   Value F 
Hypothesis 

df 
Error 

df Sig. 
Partial Eta 
Squared 

survival Pillai's Trace .979 11.535(a) 12.00 3.00 .034 .979 

  Wilks' Lambda .021 11.535(a) 12.00 3.00 .034 .979 
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  Hotelling's Trace 46.139 11.535(a) 12.00 3.00 .034 .979 

  Roy's Largest Root 46.139 11.535(a) 12.00 3.00 .034 .979 

survival * 
dose 

Pillai's Trace 
.737 .699(a) 12.00 3.00 .717 .737 

  Wilks' Lambda .263 .699(a) 12.00 3.00 .717 .737 

  Hotelling's Trace 2.798 .699(a) 12.00 3.00 .717 .737 

  Roy's Largest Root 2.798 .699(a) 12.00 3.00 .717 .737 

a  Exact statistic 
b  Design: Intercept+dose  
 Within Subjects Design: survival 
 

Next comes the results for the repeated-measures ANOVA. This requires that the 
covariance matrix of the data have "sphericity", as explained above. These data 
definitely do not; the covariances differ at different points in the experiment. 

 
Mauchly's Test of Sphericity(b) 

 
Measure: day  

Within 
Subjects 
Effect Mauchly's W 

Approx. Chi-
Square Df Sig. Epsilon(a) 

          
Greenhouse-

Geisser 
Huynh-
Feldt 

Lower-
bound 

survival .000 233.195 77 .000 .172 .216 .083 

Tests the null hypothesis that the error covariance matrix of the orthonormalized transformed dependent 
variables is proportional to an identity matrix. 
a  May be used to adjust the degrees of freedom for the averaged tests of significance. Corrected tests are 
displayed in the Tests of Within-Subjects Effects table. 
b  Design: Intercept+dose  
 Within Subjects Design: survival 

 

Therefore, when we look below at the within-subject effects, we will look at them 
in the following order: 

1. Examine the results when sphericity is assumed; 
2. Since we know that the data have failed the sphericity test, look at the 

results after the Greenhouse-Geisser correction has been applied. 
3. If these agree, we are done. If they disagree, and the G-G results show no 

effect but the sphericity assumed results do show an effect, look at the 
Huynh-Feldt corrected results. This will be our final answer. 

 
Tests of Within-Subjects Effects 

 
Measure: day  

Source   

Type III 
Sum of 
Squares df 

Mean 
Square F Sig. 

Partial 
Eta 

Squared 

survival Sphericity Assumed 7130.356 12 594.196 112.924 .000 .890 

  Greenhouse-Geisser 7130.356 2.059 3463.254 112.924 .000 .890 

  Huynh-Feldt 7130.356 2.591 2751.769 112.924 .000 .890 

  Lower-bound 7130.356 1.000 7130.356 112.924 .000 .890 

survival * dose Sphericity Assumed 561.952 12 46.829 8.900 .000 .389 
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  Greenhouse-Geisser 561.952 2.059 272.943 8.900 .001 .389 

  Huynh-Feldt 561.952 2.591 216.870 8.900 .000 .389 

  Lower-bound 561.952 1.000 561.952 8.900 .010 .389 

Error(survival) Sphericity Assumed 884.000 168 5.262       

  Greenhouse-Geisser 
884.000 

28.82
4 

30.669       

  Huynh-Feldt 
884.000 

36.27
7 

24.368       

  Lower-bound 
884.000 

14.00
0 

63.143       

 

 
Notice that the F-ratios for all of the test are the same for the two groups. Even 
though the sphericity assumption has not been supported, the corrections 
applied do not change the final story. 
 
In particular, both "survival" (the day of measurement) and the interaction 
between day and dose are highly significant explanatory factors of the termite 
numbers. This differs from the MANOVA results, and since this is a more 
powerful test, we should focus just on the repeated-measures. The tree bark 
extract does have an effective anti-termite compound. 
 
Finally, examine the profile plot. This immediately explains the results: the higher 
dose of tree bark extract led to significantly lower termite suvival. 
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Other options 
 
In the Repeated Measures dialog box, if you have multiple explanatory factors, 
you can choose which interactions to include in the model using the Model 
option. 
 
This dialog also gives you the option to choose which type of sums of squares to 
use. This is a complex topic, but essentially, if the cell frequencies in of the 
between-subject factors are unbalanced (i.e., the values between the different 
treatments are unequal), Type IV sums of squares is recommended.  
 
Additinonally, there are other procedures which can accomplish appropriate 
analysis. 

 Linear Mixed Models: When you have only one dependent variable, this 
procedure has more options for modeling the within-subject effects. 

 Paired t-test: When only one dependent variable measured in subjects at 
only two time points. 
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Graphing 
Looking at tables of means, P-values and the like may become interesting as you 
learn more about statistics, but most people want to see a graph of the data first. 
Graphs can be information-rich was to present your results to the reader in an 
instantly salient way; they can also be deceptive or confusing when poorly done. 
This section briefly introduces three common graph types. 

Bar charts 

 - Additional Topics: Formatting Chart objects 

Whenever comparing groups of cases by some single continuous variable, bar 
charts are preferred. This is true for cases where you did a t-test to compare two 
groups, or where you did an ANOVA to compare three or more groups. Below we 
will use the t-test example of leaf gas exchange in two months. However, you 
can follow the exact same procedure for a multiple-group comparison (ANOVA). 
 
First, go to Graphs > Bar. In the Bar Charts window which come up, choose 
“Simple”, then click “Define”. Leave the "Data in Chart Area" as "Summaries for 
groups of cases". 
 

 
 
 
In the Define Simple Bar window, click the “Other statistic (e.g., mean)” button, 
and move Photosyn, the continuous variable into the “Variable” box. This will 
make the bars represent mean values for each group. Select Month, the 
categorical variable, and place it in the “Category Axis” box.  
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Finally, click “Options” and select “Display error bars”. Error bars show how much 
variation there is around the mean, and are essential to report – you should 
always be suspicious of bar charts without error bars. Choose “Standard error”, 
with a multiplier of 1. Click “Continue” and “OK” to produce the graph. 
 

 
 

The resulting graph reveals why we found that the gas exchange rates differed 
significantly between these months; there was much less leaf gas exchange 
happening in July than September; atmospheric carbon is fixed into 
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carbohydrates as most twice as fast in July than September, according to these 
data. 

 
We can modify this figure by double-clicking it, bringing up the Chart Editor. First, 
click the y-axis label, and edit it to add the units. 

 
Next, click one of the two bars to select both bars, and then double-click to bring 
up the Properties window. In the Fill & Border tab, we can change the fill color for 
the bars, and in the Bar Options tab we can slide the Width slider down to 50%, 
making the bars thinner. 
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After applying these options, your chart should look like this: 

 
 
A graph like this should have a caption to the effect of: "Canopy leaf 
photosynthesis rates sharply decline over the course of a season (mean ± 1 
s.e.)". The parenthetical comment indicates that the bars represent group means, 
and the error bars represent one standard error above and below each mean. 
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Scatter plots 

 -  Additional Topics: Saving formats as a template; fitting a regression line 

 
Whenever your hypothesis is asking a question about how two characteristics 
might relate to one another over a range of values, you should use a scatter plot 
to represent the data. These plots are appropriate for both correlation and 
regression analyses. To make a scatter plot, go to Graphs > Scatter/Dot. Choose 
“Simple Scatter” from the menu that appears, and then click “Define”. 

 
 
You will now be asked which continuous variable to put along the x axis, and 
which one to put on the y axis. For a regression, consider which characteristic did 
you set as the independent variable; this should be on the x axis. For a 
correlation, this choice is arbitrary. For example, in the bird diversity used for the 
correlation analysis, species richness ("No. Species") could be the y and species 
density ("Total density") could be the x variable.  
 
To have each point labeled by the site it represents, place the Site variable in the 
"Label Cases by" box. 
 

 



Guide to SPSS       Barnard College – Biological Sciences 

  66 

 
For these labels to show up on the chart, click the Options button and select 
"Display chart with case labels". Otherwise, the points will be "labeled", but only 
when you select an individual point in the Chart Editor. 
 

 
 
 
Double-click the resulting chart to open the Chart Editor. Select the background, 
double-click to open the Properties window, and change it to white. Then select 
the points and change them to dark blue. Finally, select the text and change the 
font size from Automatic to 10 point.  
 
If you want to make more charts that look like this one, as you might if you are 
preparing a manuscript or a poster, you can save this set of formats as a 
template. After you have made all the formatting changes you want to save, go to 
File > Save Chart Template. 
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Leave all boxes checked in the next window, and choose Continue. 
 

 
 
 
Name your template something sensible, and save it in a place where you will 
find it easily. 
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The template is a file with the extension .sgt, which you will be able to use only 
for SPSS chart objects. It might be helpful to have a folder for templates where 
you store your SPSS files and data. 
 
To save this graph as an image file, exit the Chart Editor. Right-click (or Ctrl-click 
on a Mac) the chart and choose Export. 

 
 
Choose Charts Only in the Export menu, name your chart, and choose a file 
type. JPEG is a safe format for any operating system, and is reasonably good 
quality.  
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Adding a regression line 

 
In the regression example, we looked at how the density of vegetation ("Profile 
Area") predicts breeding bird population density. Open up the Simple Scatterplot 
dialog again, placing the appropriate variables in. This time, check the box "Use 
chart specifications from:", and click the File button to navigate to the template 
you stored before for the correlations.  
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The chart will have identical formatting to the correlation scatterplots produced 
previously. Here, we're going to add a regression line, so it will be clearer if we 
hide the labels for each site. Go to Elements > Hide Data Labels. 
 

 
 

Now right-click the plot and select "Add fit line at total" (or click on the  symbol 
in the Chart Editor menu bar). In the Properties window which comes up, choose 
"Linear" for the fit method. This will draw a straight line through the data. The line 
will show visually what the regression analysis calculated.   
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In the output for this example (in the Coefficients box), the intercept was 
calculated to be about 3, and the slope is 0.23. Looking at the line, this looks 
right (mentally extend the line out to the left, until height is zero, to imagine where 
the intercept is). 
 
In the Lines tab of the Properties window for this line, you can change the color 
to red, make it dashed (in the Style drop-down window), and increase the 
thickness to make it stand out more.  
 
Also, since you will likely shrink this chart down to display it, you may want to 
increase the font size for the axis labels and the R2 box. 
 
An appropriate caption for this graph would be "Vegetation density determines 
density of breeding bird populations in California woodlands (R2 = 0.225, p = 
0.008)".  
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Finer Points 
SPSS is a powerful program with many features. The best way to explore the 
capabilities of the program is to take advantage of the tutorial and help files in the 
program itself, and learn about new features as you find a use for them. Below 
are a few selected features that you may find useful as you move beyond the 
initial use of SPSS. 

Fine-tuning the data  

Data presentation 

When sharing your data with others, it can be helpful to make your variable 
names easier to understand. SPSS has a two important ways of doing this. First, 
in the Variable View of the Data Editor, you can specify not only the variable 
name, but also a Label. A label can be as long as 255 characters, so you can 
input the units used for these data, as well as comments about how they were 
collected and what the names mean. These labels appear when you hover the 
mouse over the variable name in the Data View. 
 

 
 
In addition, you can specify the Values of the data. This is most useful for 
nominal data (usually “string” type, meaning words instead of numbers), where 
you have a few categories and want to label them in helpful ways. The Values 
column is a way of using a simple code in the actual data, like 0 and 1 or “M” and 
“F”, but showing a descriptive term, like “control” and “treatment” or “Male” and 
“Female”. Do this, double-click a variable name in the Data View.  Then click the 
corresponding box in the Values column. Enter the value (like 0 or 1) and what its 
label is (like “control” or “treatment”).  
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Go back to the Data View. Select View > Value Labels. Now, instead of your 
codes, the full names appear for each value are automatically displayed. Also, 
when you click on a box in that column, you will be presented with a pull-down 
menu giving you a choice of the value names you entered. This feature is 
particularly useful for sharing data with colleagues, and making sure only the 
allowed values are entered in. 
 
Lastly, you can format how the data are displayed, using the Alignment, 
Decimals, Missing, and other characteristics of the variables. Making your data 
easier to read will make it easier for others to quickly understand what data you 
have and what you want to do with them.  
 

Working with cases 

SPSS allows you to manage your data in the Data Editor in several ways. The 
tools in the Data menu of the Data Editor allow you to change how your data are 
structured (Restructure), sort your whole data set according to one column (Sort 
Cases), or even just choose certain cases to use for a particular analysis (Select 
Cases). Much more detail is available in the SPSS Tutorial (Help > Tutorial > 
Using the Data Editor). 
 

Model Output 

SPSS generally produces more output than you need. For lab reports and even 
for manuscripts for publication, the reader only needs to see a small fraction of 
the output. The goal of producing tables and graphs is to summarize your data 
and analyses in a clear, concise fashion. Therefore, you should never simply cut 
and paste output from the SPSS Viewer into your report without "cleaning it up". 
This section demonstrates exemplary output for the four major types of analyses 
you will do: Descriptive statistics, t-tests, regression, and ANOVA. 
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All of the analyses used to produce the following output are described step-by-
step in the relevant sections of this guide. 
 

Descriptive Statistics 

 
Descriptive statistics are primarily used for exploratory tasks, and can provide 
substantial information on central tendency, the degree of variability, and 
normality of the dataset, among other uses. For these purposes, histograms are 
an efficient means of communication.  
 
For any graph or table, including histograms, there are several intuitive 
guidelines to follow: 

- Number each figure and table, and refer to it in the text by its number (e.g. 
“Figure 1 demonstrates that female heights approximate a normal 
distribution.”). 

- Axes and headings should be labeled clearly (and large enough to read 
easily), including units. 

- Figures should always be accompanied by a caption beneath. 
- Avoid unnecessary information – leaving the SPSS default mean and 

standard deviation on these graphs would be of minimal assistance, as 
the graph illustrates these points. 

- Don’t state – illustrate! If an aspect of a graph is notable, make it obvious. 
 
Again, note that to achieve such clear output for your assignments, it may be 
necessary to eliminate most of the output that SPSS produces! 
 
Most of the same guidelines apply to tables used to summarize descriptive 
statistics. One difference is that tables should have captions above, rather than 
below. 
 
SPSS provides numerous table formats that make attractive tables easy to make. 
Usually, however, they need to be edited in Word after export from SPSS (or 
customized in SPSS), as they tend to contain extraneous information. 
 
To adjust the settings for a table, first double click the table. To format, point to 
Format > Table Properties. To use a “pre-packaged” SPSS format, point to 
Format > TableLooks. 
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Table 1. Summary statistics for heights of female and male residents of Morningside 

Heights. 
 

  N Range Minimum Maximum Mean 
Standard 
Deviation 

Female Height 
(cm) 

11 31.42 154.59 186.01 167.1185 7.7612 

Male Height 
(cm) 

15 25.93 152.90 178.83 163.1684 7.4585 

 
 

T-tests 

A t-test compares two groups and looks for significant differences in the mean of 
some variable. In the example, the leaf gas exchange rates of trees were 
measured in July and September. Compare the table below with what SPSS 
produces; you need substantially less information to get your point across. This 
table shows the absolute minimum: the t statistic, degrees of freedom, and P 
value. Each table should be accompanied by a legend which completely 
describes the results.  
 

Table 2. Summary of t-test results for leaf gas exchange 

rates for three Northeastern tree species. 

 t df P 

Photosynthetic rate 

(mol m
-2

 sec
-1

) 
 5.639 229 

 
<0.001 

 
 

Working with Tables 

In the leaf gas exchange example, the t-test output first shows the results of the 
test for homogeneity of variances. When reporting our results, we only want to 
show one version of this table, for equal variances not assumed (since the 
Levene test shows that the variances are not equal).  
 
Double-click the Independent Samples Test table. Now you can edit it freely. In 
the menu bar, go to Pivot > Pivoting Trays. Each of the arrow icons represents 
one aspect of the results table. Hover your mouse over the second one on the 
bottom, and you will see the text "Assumptions". Drag this icon to the left-hand 
side of the Pivoting Trays window, which is called "Layers". 
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Now the results table has a drop-down menu called Assumptions, and you can 
toggle back and forth between the version where equal variances are assumed 
or not assumed. 

Independent Samples Test 
 
Equal variances not assumed  

  t-test for Equality of Means 

  t df 
Sig. (2-
tailed) 

Mean 
Difference 

Std. Error 
Difference 

95% Confidence Interval 
of the Difference 

            Lower Upper 

Photosyn 5.639 228.852 .000 2.57474 .45657 1.67511 3.47436 

 

ANOVA 

See the Analysis of variance section for a complete description of how to conduct 
an ANOVA. This example shows the results of an analysis of how rising CO2 
might affect plant growth rates. SPSS produces a table which is very useful, and 
shows all the major components of the ANOVA test: Sums of Squares (SS), 
degrees of freedom (df), mean squares (MS), the F statistic, and the P value. 
While you may not know what these all mean, it is useful to report them so that 
the reader can see exactly how you got your results. There are other formats for 
presenting ANOVA results, but this a standard one.  
 
Note how the P value is reported not as “.000”, which is what SPSS returned, but 
rather as “>.001”. This is a more accurate representation; a probability can never 
really be zero, definitely not in biology. Also, because the P value is below the 
critical value of 0.05, you should highlight it in bold. This way if you have many 
ANOVA results, the reader can quickly refer to the significant ones. Also note the 
way the table lines are drawn; this is standard format for publication. 
 

Table 3. Summary of analysis of variance results for the effects of elevated 
atmospheric CO2 concentration on plant growth. 
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 SS df MS 
 

F P 

Between 
Groups 

3.089 2 1.545 45.237 <.001 

Within Groups 2.458 72 .034     

Total 5.547 74       

 
In addition, you should produce a bar chart with error bars, just as you would do 
for a t-test analysis. An example bar chart from these data is below. 
 

 
Figure 5. Atmospheric CO2 concentration significantly affects relative  

growth rate of greenhouse plant seedlings (bars are mean + 1 SD). 
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Examples from Portney & Watkins 

Repeated-Measures ANOVA 

 - Additional Topics: Multiple comparisons for repeated-measures ANOVA 

Portney & Watkins give an example of a simple repeated-measures analysis of 
variance, in which nine subjects had their forearm strengths measured in three 
different positions (Table 20.3, p. 444). In this example, there is no between-
subjects factor to group the subjects, only one within-subjects factor, the elbow 
flexor strength. 
 
To see how this example looks in SPSS, load the data ElbowFlexor from the 
workbook Portney_Watkins.xls. Then go to Analyze > General Linear Model > 
Repeated Measures. 
 
Recall that the key step in running a repeated-measures ANOVA in SPSS is 
correctly defining the within-subject factor. Here, name the factor "forearm", and 
set it to three levels. Click "Add", and then name the measure "strength". Click 
"Add", and then "Define". 

 
In the Repeated Measures dialog, select all three measurement variables 
(Pronation, Neutral, and Supination), and click the right-pointing arrow to move 
them into the Within-Subjects box. There is no between-subjects variable in this 
example. 
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Choose Plots, and add a "forearm" plot.  

 
Run the analysis, and examine the results. The first major difference between the 
SPSS output and the example output in Portney & Watkins is that SPSS by 
default runs a multivariate analysis of variance (MANOVA). We can ignore this 
for now.  
 
Mauchly's Test of Sphericity tells us which version of the ANOVA we should use. 
These data do not violate the assumption of sphericity (p = 0.239), so we can 
focus on the "Sphericity Assumed" results. This table looks very similar to the 
table on p. 445. 
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 Mauchly's Test of Sphericity(b) 
 
Measure: strength  

Within Subjects 
Effect Mauchly's W 

Approx. Chi-
Square df Sig. Epsilon(a) 

          
Greenhouse-

Geisser 
Huynh-
Feldt 

Lower-
bound 

forearm .664 2.861 2 .239 .749 .883 .500 

Tests the null hypothesis that the error covariance matrix of the orthonormalized transformed dependent 
variables is proportional to an identity matrix. 
a  May be used to adjust the degrees of freedom for the averaged tests of significance. Corrected tests are 
displayed in the Tests of Within-Subjects Effects table. 
b  Design: Intercept  
 Within Subjects Design: forearm 
 

Now we can see some large differences in the presentation of results. What 
Portney & Watkins present in four lines of one table, SPSS presents over two 
tables, in a total of 10 lines. The story that we are looking for is in the first line of 
the first table, the within-subjects effect of forearm position on elbow flexor 
strength. There is a highly significant relationship here (p < 0.001). The other two 
lines show how much of the variation in strength measurements within subjects is 
not due to the treatments ("Error(forearm)"), and how much is just due to 
differences between subjects (the Error term in the Between-Subjects table).  
 
 Tests of Within-Subjects Effects 
 
Measure: strength  

Source   
Type III Sum 
of Squares df 

Mean 
Square F Sig. 

forearm Sphericity Assumed 736.889 2 368.444 50.338 .000 

  Greenhouse-Geisser 736.889 1.498 492.065 50.338 .000 

  Huynh-Feldt 736.889 1.765 417.463 50.338 .000 

  Lower-bound 736.889 1.000 736.889 50.338 .000 

Error(forearm) Sphericity Assumed 117.111 16 7.319     

  Greenhouse-Geisser 117.111 11.980 9.775     

  Huynh-Feldt 117.111 14.121 8.293     

  Lower-bound 117.111 8.000 14.639     

 
 Tests of Between-Subjects Effects 
 
Measure: strength  
Transformed Variable: Average  

Source 
Type III Sum of 

Squares df Mean Square F Sig. 

Intercept 16428.000 1 16428.000 50.470 .000 

Error 2604.000 8 325.500     
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Post hoc tests for repeated-measures ANOVA 

After discoving that a within-subject factor makes a significant difference in 
explaining the variation in the data, you likely want to know where that difference 
is, exactly. One of the measures may account for all of the variation, perhaps. 
This requires a post hoc, or multiple comparison test. In SPSS, it is possible to 
analyze the diffences between measurements with a paired t-test. 
 
Since you want to compare multiple groups using the same data, you must adjust 
the analysis to acknowledge that you are doing multiple comparisons. This is 

done by adjusting the  of the analysis, using what is known as a Bonferroni 
correction.  
 
This is a simple procedure. If for example you have three within-subject 

measures, you need to divide your  by 3. So if you normally use  = 0.05, now it 

becomes 0.05 / 3 = 0.017 = FW, the family-wise error rate.  
 
In SPSS this adjustment is made in the paired t-test options dialog. First, using 
the example data from above, choose Analyze > Compare Means > Paired 
Samples T-Test. Select each pair of comparisons to make, and place them in the 
Paired Variables box. 
 

 
 

Here is the trick. You must manually change the error rate, which here is 
presented as the confidence percent. To change this correctly, enter in the value 

100 – FW; here this is 100 – 0.017 = 99.983. 
 

 

The results of the paired-samples t-test show that pronation differes highly 
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significantly (p < 0.001) from either neutral or supination postures, but the latter 
two do not differ significantly from each other (p = 0.127). 
 
 Paired Samples Test 
 

  Paired Differences t df 
Sig. (2-
tailed) 

  Mean 
Std. 

Deviation 
Std. Error 

Mean 
99.983% Confidence 

Interval of the Difference       

        Lower Upper       

Pair 1 Pronation - 
Neutral 

-10.22 3.77 1.256 -18.506 -1.938 -8.140 8 .000 

Pair 2 Pronation - 
Supination 

-11.78 4.71 1.570 -22.137 -1.419 -7.500 8 .000 

Pair 3 Neutral - 
Supination 

-1.56 2.74 .915 -7.588 4.477 -1.701 8 .127 
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